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When William Volk first learned about the Amiga computer in early 

1985, he was immediately interested in learning more about this 

"revolutionary" new machine. At first, mmors were more prevalent 

than factual data, but the overall scheme of things remained consistent. 

Commodore and Amiga were developing a computer that would change 

the personal computer industry in several important markets. The 

market that caught Bill's attention was graphics and Computer Aided 

Design. 

William had a long history working with graphics. From his early days 

at Avalon Hill to his present position as Technical Director for Aegis 

Development, his love of computers centered around moving pixels 

and color. The Amiga seemed like the machine that would make high 

speed supergraphics affordable. 

Once he had the opportunity to use an early prototype machine, Bill 

knew the die had been cast. People who would have never before 

considered using a personal computer to create with could turn to 

the Amiga. He wrote a memo to Aegis President David Barrett. 
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April 09 

MEMO: 
TO:D.BARRETT 
FROM: WVOLK 
RE: CBM AMIGA MACHINE 

Dave -

OpportlIDity knocks but once .... 

In the case of the Commodore Amiga, opportlIDity is breaking 
down the door and screa:rning at the top of its lungs "It's 1979 
all over again!" 

If you turn your WayBack machine to the year 1979, you will 
recall that this was the year that entire industry grew up around 
the Apple II. At the time the Apple II presented the industry 
with some "radical" features. These were: 

1. High Resolution (for then) color graphics. 
2. Expandability. 
3. Reasonable cost. 

I think we have the same possibilities with the Amiga... 

The y' .Imlng on B'll'DIs part w 
eveloper's Conti as eXcellent. Aegis . 

erence in M was Invited 
ofhis Or Aegis' intent' Onterey, California Ba to the Amiga

IOns. . rrett made n 1-2 o secret 
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April 18 

MEMO: 
TO: W.VOLK 
FROM: D. BARRETT 
RE: AMIGA CONFERENCE 

Bill-

It seems you'll be attend.ing the Amiga Developer's conference 
in May. As the preferred development environment for this 
machine is "C", I've dropped several hundred pages of relevant 
documentation - along with 9 sixpack's of Foster's off in your 
area. Please review the data and drink the lager. When you 
recover, you'll understand our direction. This machine was 
conceived for the CAD market. We will not miss one second in 
commencing a developmental project around the Amiga and 
CAD. When you return from Monterey, all of the fine points 
should be in place. I look forward to your report. 

. d had bargained for . The 
more than Bill or Davl demonstration 

C nference was . ry Each new 
The 0 . was extraordlOa . f the attending 

. to the Amlga h . plause rom
reaction d excitement. T e ap d Santa Monica, 
revealed new power an af . g When Bill returne to . CAD n 

loper's was almost de ent . the Amiga in designlOg a 
deve . kin of ways to use 

he was already thlO g 


software system. 1-3 



INSIDE 
A EG IS 

DRAW 

May 29 

MEMO: 

TO: D. BARRETT 


FROM: WVOLK 


RE: MONTEREYCONFERENCE 


Dave 

This memo really won't make sense until you see this machine. 
The Amiga is more than I expected, too good of a computer 
not to make a lasting impact on the entire industry. The 
hardware line drawing and area fills will make CAD software 
perform beyond the level of currently available hardware. More 
importantly the system multitasks! Plots that take hours won't 
prevent designers from USing the machine. We should make a 
commitment to "work with" the multitasker in all our Amiga 
software. 

The big surprise was the quality of the documentation for a 
new computer. I'm also impressed by the structured design of 
the graphics routines. Multiple window applications should run 
as fast as Single Window applications, huge implications in a 
professional workstation. I can't wait to get my hands on this!!! 

Within Week . 
s, AegIS had . . 

to Work With the An . lOltiated a project 

CAD project Was labe~~: .~;d create a series 0;:::' headed by Volk, 
808". Ware projects. The 

At first, the plan

of th was to use 


e early "c" a series of A .
compile' mlga co

experimentation, it . . r s available fOr th mputers and One 
Was deCided th e machJne. Aft 

at another er some 
rOUte mUSt b 

. e Used as 
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the performance of the compiler being tested was only marginal. Manx 

provided the solution with their Aztec C system. 

Bill spent many hours working out the overall specification and design 

for 6808. Once approval for the project was granted by Barrett, Aegis 

contracted with Red Shark Software to write the actual code. Bill 

continued to supervise and participate in the project. 

The approved development system included a 512K Amiga, 1 MB RAM 

upgrade, 20 MB hard disk, and the Sony KV1311 CR RBG monitor. 

The Aztec compiler was used along with Metacomco's editor and some 

Aegis development tools. 

Aegis Draw uses the Amiga FFP (fast floating point) math libraries 

for faster math operations. All Draw data files are text files that can 

be edited with ED, TxED, or other Amiga text editors. The file requestor 

was created by Charley Heath of MicroSmiths Inc. and converted into 

Aztec C by William Volk. The graphics system used in Aegis Draw 

is based on portions of the GKS and CORE graphics systems. Aegis 

Draw allocates memory "on the fly" for all graphics objects, and will 

take advantage of additional FAST memory. 

By the end of November, a basic shell had emerged. Simple tools were 

working and a drawing could be created. The press were given a 

demonstration of Aegis Draw at the Fall Comdex in Las Vegas. Red 

Shark slowed development while Commodore updated the Amiga 

Intuition software environment from 1.0 to 1.1. 

Aegis Draw was first shown to the public in January of 19R6 at the 
Consumer Electronics Show in Las Vegas. By this time, plotter support 

had been added and the user interface began to take hold. The 
developmental process was accelerated. Design work was begun on 
Aegis Pro-Draw. 

No computer system can be regarded as a success without complimentary 

and widely available software. Never before has a full featured CAD 
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product been available on such an inexpensive machinc. Finally, the 

pricc of the software allowed even the most casual computer user 

to take advantage of the opportunity provided by the Amiga. The Aegis 

Draw project represents a three way commitment to the Amiga, the 

CAD market, and to the computer consumer. 

For William Volk, Aegis Draw is a labor of love. For Aegis, it represents 

the company's premier product line. The following pages will take 

you through Aegis Draw step by step, window by window. Enjoy. 

, '. 
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CHAPTER 


CAD Concepts 


How to Use This Book 

Inside Aegis Draw is broken into three separate sections. Section One 

provides first time users with an overview of the CAD environment 

and some of the possible uses for CAD software. If you are an 

experienced user, you probably aren't even reading this. You're probably 

looking at Section Two, the tutorial describing the functions of Aegis 

Draw and how to create a drawing. Section Three is a reference section 

for advanced users. Also, Appendix A contains a list of commands by 

menu with references to more material. As you read through the book, 

feel free to jump around from section to section looking for the data 

most important to you. 

In this book we use a different rypeface when referencing menu 

commands. The word will appear in bold as you would see it on the 

screen. This rype of rype change is used when the command is being 

described directly to avoid confusion. 

1-1 
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CAD and Aegis Draw 

CAD is an acronym for Computer Aided Design. Engineers , designers, 

architects, graphics artists are among the groups of professionals that 

use CAD systems. A CAD software system uses the computer's ability 

to process, store, retrieve, and display accurate computer graphics. 

Aegis Draw is a CAD program for creating accurate scaled drawings. 

It creates a "database" for the elements of the drawing, and allows 

you to view any section of the drawing - even multiple sections at 

the same time' 

The Amiga display acts like a "window" into the drawing. The drawing 

can have a far greater resolution than the actual display. For example, 

you may zoom into the elevations.drw drawing (provided on the demo 

disk) to a point where the display is smaller than the dot on the letter 

"i". The display is just a representation of what is in the database 

more on this later on. 

Aegis Draw is a multi-window software system. If you have 512K of 

memory you may open two windows. These may be separate drawings, 

or different views/ windows of the same drawing. Expansion memory 

beyond 512K will give Aegis Draw even more flexibiliry and additional 

windows to work with. Adding a hard disk system will allow for rapid 

access to data and parts. Remember, Aegis Draw is not copy protected 

and can be loaded and operated using a variery of hard disk systems. 

Since Aegis Draw maintains a database of the drawing elements, you 

can select elements and drag, clone, rotate , and size them just by clicking 

on their borders. Unlike a paint system Aegis Draw knows what is 

on the display. If you decide to move a circle, Aegis Draw will know 

where the circle is in the drawing. The elements that make up the 

display have "real" coordinates, not just graphics pixels (as in a paint 

system) . This means you may work on a close-in detailed section of 
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a drawing and modify and update two displays at the same time: the 

zoom window and the main drawing window. 

CAD Concepts 

Before anything can be built, it must go through a developmental 

process called design. Everything (even this book) must be organized 

into some sort of structure in order for the original concept to function 

properly. 

Years ago, design wcrk was done strictly by hand. If a Ford designer 

wanted to come up with a new car, he had to use his sliderule, 

straightedge, and pencil and paper. A writer used his typewriter to 

build a storyline, and a company Vice President of Operations used 

a triangle and pen to create an organizational chart of job functions. 

Although computers have been around since the late 40's, it wasn't 

until the 1960's when IBM introduced their 360 line of computers 

that CAD began to surface. Some designers at Lockheed wanted to 

automate the design process and began working on a software system 

for the IBM 360. Soon, Lockheed had created a completely separate 

subsidiary to continue CAD development. The company was called 

CADCAM. 

Lockhheed, McDonnel·Douglas, and General Motors were the first 

major CAD users. They used the software for the purpose of developing 

their own products. No retail or other types of sales were made. Each 

new software system often went through the same developmental 

process as each company was afraid of their competitors stealing their 

code and beating them in creating new products. An ironic twist to 

early CAD software development is in the process itself. The early 

CAD designers used pencil and paper to design the operation of the 

computer software. 

1-3 
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'In the 70's, the DEC PDP-II became one of the most popular computer 

systems available. A commercially available CAD system was released 

by a design company called Applicon. Within a few years, many 

companies were developing CAD software. Today, Aegis Draw running 

with an Amiga represents more power than many full scale mainframe 

systems of the 60 's. 

Who Uses CAD? 

Computer graphics can be used by anyone . Some of the more common 

users of graphics include electrical and structural engineers, architects, 

motion picture companies, and students. An electrical engineer can 

design a circuit board and make changes to his design in seconds. 

An architect can visually create an entire building using graphics 

software. 

A computer graphics system is of value to others as well. For example, 
Aegis Draw can be used to create a company's organizational chart. 

The real value of using a CAD system isn't always in the actual input 

of information. Sometimes, modifications or additions to a drawing 

bring out the unique power of a graphiCS system. Imagine creating 

a drawing of an electrical plan that shows lighting fixtures. After the 

plan is complete, you discover you've made an error and each light 

is three inches too wide. In a manual system, you would be forced 

to completely redraw the plan. With Aegis Draw or a similar software 

system, you can adjust the plan and replot it in a matter of minutes. 

Computer CAD Requirements 

Although CAD software is unique because it is always performed with 
the use of a computer, not all computers are capable of CAD operations. 

In order to complete a CAD project, the computer must be able to 

perform certain tasks. These include the ability to display graphics 

on a terminal (monitor), redraw those graphiCS (very quickly) as they 

1-4 
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are mociitled , and store enough information so a complete clrawing 

can he rendered. The use of color is not mandatory, but does increase 

the tlexibiJity of a CAD system. 

Along with the internal requirements. a CAl) computer system must 

be able to handle a varietv of input and output devices. An input device 

includes the keyhoard , a mouse. digitizer. or lightpen . Output devices 

include plotters, printers, or video. 

The Amiga is more than qualified to handle all of the requirements 

listed herein. The next chapter discusses the design concepts behinu 

Aegis Draw and how they apply to the Amiga. 
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2 An Overview of Aegis 
Draw 

Aegis Draw and the Amiga 

The Amiga represents a breakthrough in personal computer graphics. 

You may have seen animations, games, and paint systems that take 

advantage of the speed and resolution of Amiga graphics. These 

advantages also playa role in CAD graphics. On a typical microcomputer 

CAD system most of the time is spent drawing and filling shapes on 

the screen. The Amiga has a set of custOIll chips which speed up the 

process considerably. You spend more tiIlle drawing and less tiIlle 

waiting. 

The Amiga's system software also works to the advantage of the Draw 

program. Multi-tasking allows the AIlliga to plot a drawing without 

making you wait for the plot to finish. This means you can work on 

an existing drawing and a completely new program at the same time. 

The Illulti-window portion of the operating system allows Draw to 

display several windows of drawings, or even different views of the 

same drawing. Pull down menus and the mouse provide a powerful 

interblce to the drawing system. 

Draw can also Olltput bitmap files in IFF format. This is tile format 

used bv most Amiga paint systems (Aegis Images™, Deluxe Paint"", 
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and Graphicraft™) . It allows you to integrate your drawing system 

with paint and presentation graphics programs. In the near future word 

processing software will allow you to insert these bitmaps into text 

documents. 

What is a Drawing? 

In order to use Draw to YOllf best advantage, some understanding of 

what goes on Inside the program can be useful. You don 't have to 

know about curve fitting algorithms or scan line conversion to be 

proficient at Draw, just a basic understanding of the contents of a 

drawing will do. 

When you use a word processor you expect to be allowed to go back 

to the line you just typed and change the phrase "ant eater" to 

"arddvark." This is the type of advantage Draw gives you over a paint 

package. If you use a paint system and want to move a circle to a 

new location or change its size, you may not be able to. Paint systems 

can manipulate pixels (dots) on the screen, but they don't "know" 

that a circle command made those pixels appear. Unlike the word 

processor which knows what a character, word, and paragraph are , 

a paint system doesn 't have an understanding of the circles, arcs, and 

lines used to create the painting. The paint system knows about pixels, 

pixels, and pixels. 

Enter Aegis Draw. Draw is like a word processor for graphics. A word 

processor processes text. Draw processes graphics. For example, if 

you draw a red circle with a radius of 50 units (more on units in 

a bit) at a location of x= I 00, y= 100 , Draw will store that circle in 

memory something like this: 

A Circle 


Radius 50 


Center at 100, 100 


Color Red, filled with pattern 3 
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Later if you decide to move the circle, Draw will modify the Center 

values. The pixels on the screen change (the old circle is erased and 

a new one drawn in the new position) because Draw redisplays only 

the portions of the drawing which change. The term for this type 
ofsystem is "structured drawing". A paint program creates an "unstructured 

drawing". 

In Aegis Draw, the coordinates, radius, and other values are completely 

independent of the screen. The program uses a High Resolution/ Non

Interlaced display of 640 by 200 pixels, but a drawing can have billions 

of units. The display is only a representation of the drawing; zoom 

in and you see more detail. In fact, you could draw a picture of the 

Earth and zoom in to read a piece of paper on someone's desk. This 

would be impossible for an unstructured system like a paint package. 

There are more practical purposes for this resolution. Plotters have 

quite a bit more resolution than the screen of a computer and they 

draw smooth lines (no dots). A plotter can be used to create accurate 

scaled drawings. You may set the size of the drawing to any amount 

you want, thus allowing you to have draWings that represent real world 

objects. The size can be changed at any time. This can be useful if 

you decide you need more room for that office plan than you expected. 

The "origin" of the drawing is where it all starts. When you first start 

the program you will see a 0,0 origin on the rulers in the lower left 

side of the screen. Draw's origin is always in the lower left of the 

screen. It is based on the Cartesian coordinate system. If you want 

your drawing to start at a different origin, say 100,100, Draw will let 

you. For some draWings you may want to set the origin to a negative 

value (-100,-100) to give yourself a little working space. This is also 

allowed in Draw. 

A large drawing can get quite cluttered, particularly if it has plumbing, 
electrical, and other information displayed on top of the basic plan. 

Draw allows you to break up a drawing into different layers, and to 

have any number of these layers displayed in any of the windows. Each 
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object in a drawing sits on a panicular layer and each window can 

show any of the 250 layers in a drawing. 

The windows in Draw show a portion of the drawing. Each window 

can show a different drawing or the same drawing. Windows also have 

unique background, ruler, and grid colors. It 's important to remember 

when you look at a window that you are only looking at a representation 

of the drawing. 

Uses and Functionality 

It's obvious Draw can he used for creating plans of buildings, circuit 

boards, and mechanical devices. Some other uses of Draw aren 't quite 

as obviolls sllch as organization charts, maps, how-to guides, and 

technical drawings to name a few. 

Basically Draw is useful anytime you need to create an accurate drawing 

of anything. [f you an: trying to arrange the space in an office for 

example, Draw becomes a good tool at "what if" calculations. The 

dimension lines in Draw are not static, they will recalculate when 

resized . Often used shapes can be stored in a parts library for future 

drawings. These parts can be resized and rotated at will. This allows 

for great flexibility in using Draw as an idea tool. 

Aegis Draw's Organizational Layout 

The Aegis Draw program is "Tool Based." This is a simple concept 

akin to drawing by hand. If you were rendering a drawing with a pencil, 

your tool would be the pencil. Need to erase several things' Just reach 

over and grab the eraser. Want to draw several circles' Use the "circle 

tool ", typica lly a protractor. 

In Draw these tools appear in a Tools menu . The menu is arranged 

in two columns. The left column is reserved for tools that create. The 

right column holds tools to mOdify those creations. If you want to 

2-4 



AN OVERVIEW OF A E GIS DRAW 

draw several circles, just select the Circle tool. To resize the circles, 

use the Sizer tool. 

Ifall you could create was black and white line drawings, Draw wouldn't 

be as useful. Luckily Draw allows you to change colors, line patterns, 

line weight (thickness), till patterns, and many other options. If you 

use the Color menu and select the color blue, all the shapes you create 

will be blue until you change the color again. The same is true for 

line patterns, fill patterns, and several other options and preferences. 

These settings are not cast in concrete, the Color tool will let you 

change an object's color, pattern, layer, etc., after it has been created. 

Sometimes you need to do something other than create or manipulate 

a single object. Instead you may want to deal with a group of objects 

or to Zoom In on a section of the drawing. In Draw these types of 

actions are temporary tools. When you are fInished with the temporary 

tool, Draw gives you back your prior one. If you were drawing 

circles and selected Erase from the Edit menu, Draw would give you 

back the Circle tool when you finished the Erase. 

The Draw display is divided into several windows. Windows have cqtain 

options which can be changed at will. Background, ruler, and grid 

colors can be changed on an individual basis for each window in your 

display. The display (or non display) of rulers and grids is also selectable 

on a window by window basis. 

There are also options affecting the entire Draw program. These include 

the color menu, line patterns, fill patterns. and line weight. Other 

options that affect input are Grid Snap, Data Snap, and Rounding. 

They affect the result of a shape when you use a tool. Crosshairs 

On/Off and Numeric Display affect what YOll see for every window 

on the screen. 

The most important thing to remember about Draw is this: 

"The display is ONLY a representation oj the Drawing" 

Now it's time to make Aegis Draw work for you. 
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3 Starting Aegis Draw 

Loading Aegis Draw, eLI and Workbench 

Aegis Draw is shipped with Workbench. You can gain additional memory 

for drawings by running the program from the CLl (Command Line 

Interpreter ). 

To start Aegis Draw from Workbench: 

• 	 Turn the Amiga on and boot the computer with the Kickstart disk. 

• 	 When the the screen asks for the Workbench disk remove the Kickstart 

disk and insert the Aegis Draw disk. The Workbench desktop will appear. 

• 	 Double click (2 rapid presses of the Selection button) on the Aegis 

Draw icon. The Draw program will load and you will be presented 

with the main screen. 

To start Aegis Draw from ell: 

• 	 At the CLl prompt enter: Draw 
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An Overview of the Menu System 

Almost every action performed by Draw is done through a menu 

selection. To begin drawing circles, for example, requires selecting 

a circles option from a menu of shapes. Draw is then ready to draw 

circles using the mouse. 

The main menu system for Draw is located in an area at the top of 

the screen known as the Menu Bar. When Draw first boots, this area 

displays the title of the program (Aegis Draw) and the version number 

you are using. 

By pressing the Menu (right) mouse button the bar changes to display 

the main options of the menu. Placing the cursor on one of these 

selections while holding the Menu button down will cause the menu 

options of that category to be displayed in a box beneath it. 

By holding the Menu button down and dragging the cursor downward, 

a highlight bar appears. The bar may be moved up and down through 

the options. When an option is highlighted and the Menu button 

released, that option is then selected. In this book we refer to this 

action as "selecting" or "choosing" an option. 

In addition to these menu choices some menu options have sub-menus 

attached to them. In this case another menu box will open to the 

right of the option with the various choices available. The cursor must 

then be moved over into the new box and onto the sub-option desired 

before the Menu button is released. 

To see a santple sub-menu box: 

• 	 Hold the Menu (right) mouse button down. 

• 	 Move the cursor onto the Project menu selection. A box of menu 

options will open beneath it. 
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... 

Figure 3.1 The Main Menu Bar. By pressing the Menu button. the nrle bar changes to reveal the main options of 
the Draw program. Placing the cursor on an option will open a list of funaions beneath it. Some funaions may 
have sub-menu items such as the one displayed. From the Project option you may choose to Open one of two 
different types of files. Each menu option breaks the functions of the program into logical areas. The funa/ ons under 
Project relate mainly to opening. saving, and printing files. Edit commands allow you to manipulate a seleaed 
area in different ways. The Tools option contains the basic tools for drawing and editing objectS. The view of 
the current window can be adjusted With the Display I\.ma/ons, and the way objectS are created may be controlled 
from Options. Preferences is a liSt of on/off switches also controlling different aspects of objea creation. The last 
menu, Colors, is the color palette. 
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• 	 Drag the cursor downward until the highlight bar is on the Open 

option. A sub-menu box will open to the right displaying the different 

kinds of files you can open. 

The main menu options appearing in the Menu Bar are: Project, Edit, 

Tools, Display, Options, Preferences, and Colors. 

The options under this selection are for creating new drawings, opening 

and saving drawings, clearing drawings from internal memory, and 

printing or plotting. The option for leaving Aegis Draw is also here. 

The editing functions listed here are for making changes to an area 
of a drawing. You can cut, copy, and paste segments of a drawing 

similar to the way you might cut and paste in a word processor. There 
are also commands for distorting and rotating areas, or changing the 

size, color, line pattern or line weight of all the objects in an area. 

You can group objects together to create parts which may be plugged 

into different areas of the drawing or even into other drawings. The 

"oops I goofed" function is also found here. It's called Undo and it 

removes the last action performed and returns the drawing to its 

previous state. 

This is really the heart of the Draw system. All the main tOols for 

creating the shapes in a drawing are located here. Lines, circles, 
rectangles, arcs, text, freehand shapes, and dimension lines are all 

chosen as options off this menu. There are also tools for manipulating 

the shapes once they have been created. You can move, copy, rotate, 

erase, resize, and change the characteristics of any object. 
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Display 

Options 

All the commands under Display control the view of the drawing in 

the active window. You can turn the grid and rulers on or off, and 

change their color or the color of the background. A crosshair for 

precision alignment is also available. The level of detail displayed can 

be adjusted from a full view of the drawing to a blow up of a small 

region. The command for choosing which layers will be displayed in 

a window is also under this menu selection. 

The Options menu allows you to control different aspects of the 9rawing 

such as the thickness and pattern of lines used to create shapes, or 

the tlJJ pattern used for solid shapes. Other aspects controlled here 

inclUde the grid size and line pattern , the type of units used with 

rulers, the level of precision, plotter scale, and the size and origin 

of the drawing. 

Preferences 

Options located under this menu selection are all on l off switches. 

Like Options, they control different aspects of the shapes and how 

they are drawn. You can specify whether shapes will be tilled or outline, 

and which layer is currently active so all shapes created will be assigned 

to it. The numeric display of the cursor location , grid snap, data snap, 

rounding, and smoothing are all controlled from here as well. 

Colors 

The last selection is the color palette. This is where you choose the 

active color to work with. There is also an option for changing the 

hue of the colors in the palette. 
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Menu Shortcuts 

If you have several choices to make in the menus you can make them 

all at once without having to wait for each job to finish. For example, 

to set the background to black and the rulers to red requires selecting 

first black from the Color menu, then Set-Background from the Display 

menu, then red from the Color menu, and finally Set-Rulers from the 

Display menu. If you take each job one step at a time (pull down 

each menu and release it), you must wait for the screen to repaint 

with a black background before you select the red rulers and then 

wait for the screen to repaint again. 

A faster way to perform these operations is provided by the Amiga 

system. You may perform all the menu selections at once by holding 

the Menu button down continuously and pressing the Selection button 

any time the highlight bar is on the command of your choice. Using 

this method the steps above would look like this: 

• 	 Hold down Menu button. Move the cursor to the Color menu. 

• 	 Move the highlight bar to black and press the Selection button. 

• 	 With the Menu button still down move the cursor to the Display menu 
and drag the cursor until it is over Set. A sub-menu box will open 

to the right with the available options. 

• 	 Move the cursor until the highlight bar is on Background and press 

the Selection button. 

• 	 With the Menu button still down move back to the Color menu and 
follow the above steps to set the rulers to red. 

• 	 Once you have made all your choices with the Selection button, release 
the Menu button and all the actions will be performed in the order 

of their selection. 
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Using the Mouse 

Almost every function in Draw is initiated or performed with the mouse. 

The two buttons on the mouse always perform the same action with 

any function. Use the Selection (right) button to choose or create 

objects and the Menu (left) button to work the menus or cancel the 

current action. So whether you are creating circles or selecting an 

area of the drawing to erase, the Selection button performs the action 

and the Menu button cancels it. 

Most tasks in Draw are two step tasks. They require a press of the 

Selection button to begin (the start of a shape or to choose the object 

to change), a movement of the mouse to enact the task and another 

press of the Selection button to end. During the task a "rubberband" 

line displays the changes being made and reflects the movement of 

the mouse. When the rubberband line is correct for the change being 

made, the last press of the Selection button is performed to conclude 

the task. Anytime between the two Selection button steps the Menu 

button may be pressed to cancel the operation. 

Some operations like finishing a line require a double click of the 

mouse. Double clicking means pressing the Selection button twice 

in rapid succession. 

Besides manipulating the menus and shapes in a drawing, the mouse 

is used for controlling the windows and moving them about on the 

desktop. Moving windows is done by dragging. Dragging requires 

placing the cursor on the object to drag (in this case the window 

frame) and holding the Selection button down while moving the cursor 

to a new location on the screen. Scroll bars are other gadgets that 

use dragging. 

Alternative devices to the mouse may be used with Draw and details 

about them can be found in Chapter 19. 
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Using the Amiga Gadgets 

Buttons 

Sliders 

Edit Boxes 

Draw makes extensive use of the Amiga interface to simplify the CAD 

process. Besides menus and windows the program also uses buttons, 

sliders, and edit boxes. (If you are already familiar with these Amiga 
functions you may want to skip ahead and briefly scan the material 

on edit boxes. There is a complete list of edit commands.) 

Buttons are devices for performing a single action or for making a 

choice (yes/no for instance). They typically appear in requestors and 

are used to exit the requestor with a particular action occurring. For 

instance if you choose the command Kill Drawing a requestor appears 
confirming the operation with the question: Kill the Drawing? At the 

bottom of the requestor are two boxes, one with the word Yes and 

the other No. They are the buttons for exiting this requestor. You 

answer the request by clicking on one of these buttons. 

Sliders control a value that has a range. For example, the Modify Colors 

requestor has sliders for controlling the amount of Red, Green , and 
Blue in a color. A slider appears on the screen as a rectangle (which 

represents the range) and a marker (representing the current value). 

You operate a slider by dragging the marker (place cursor on marker, 

hold Selection button down, and move mouse) to a new position. 

Edit boxes are used for entering values to Draw. They appear in 

requestors as rectangles. They may already hold a value (the last text 
entered or the current value) or appear empty. To use an edit box 

yOLl must first select it by clicking inside it. When a cursor appears 

inside the box it is ready for use. 
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The edit box uses an "insert tex t" method rather than " type over". 

This means any text YOll enter will be inserted in any existing text 

at the cursor position. If text already exists in the box you will have 

to delete it first before entering text to replace it. To do this , move 

to the end of the current text and backspace over it or use the DEL 

key to delete the text one character at a time . Below is a list of command 

keys allowed in the edit boxes. 

Keys(s) Function 

(left arrow) or (right arrow) Move the cursor one character in 

the desired direction. 

SHIFT (I arrow) or (r arrow) Move the cursor to the beginning 

or end of all text. 

DEL Delete the character under the cur

sor. 

Backspace Delete the charac ter to the left of 

the cursor. 

RETURN Finished with the text. In the case 

of a single edit box it will also have 

the effect of selecting the OK button. 

Right Amiga - Q Undo (cancel) the last editing 

change. 
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CHAPTER 


Learning Graphics 
Primitives 

This chapter is a step by step tutorial on the basic tools found in 
Aegis Draw. Chapter 5 continues the tutorial with a tour of the editing 
features and some of the more advanced tools. Chapter 6 finishes 
the step by step tutorial. 

When Draw first loads, an initial window with the title "Untitled" is 
displayed. This is the current active window. You may load drawings 
into this window from disk or create a new drawing. 

The left and bottom borders of the window contain the rulers. Rulers 

provide a means of accuracy for both creating and placing objects. 

Initially the rulers are preset to 140 units by 150 units. 

First, resize the window to full screen to provide a larger working 
area. 

To resize the window: 

• 	 Place the cursor on the resize box of the window. This is the gadget 
in the bottom right corner where the window borders come together. 

.--..... 
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• 	 Hold the Selection (left) button down and drag the cursor to the bottom 
right comer of the screen. A ghost frame will appear around the window. 

As you move the cursor you will notice the frame follows it. 

• 	 When the frame extends to the bottom and far right of the screen 
release the Selection button. The window will be redrawn to the new 

size. You may resize any window in this manner. 

Every drawing is just a collection of shapes combined together to make 

a whole. The tools to make these shapes are under the Tools menu . 

Hold the Menu (right) button down. The third menu option from 

the left is the Tools menu. Move the cursor until it is over Tools. 

The different tools available will appear under the option. The selections 

on the left are for creating objects and those on the right are for 

editing or manipulating them. 

One of these tools is always selected. The default tool is Lines. This 

means the mouse is ready to create lines. Now try it. 

Draw a square with the Line option: 

• 	 First, select a color to work in. Pull down the Color menu and move 
the highlight bar until a dark color is chosen (shows up better on 

the white background) and release the Menu button. 

• 	 Pull down the Tools menu and be sure Lines has a check mark next 
to it. If it doesn 't, hold the Menu button down and move the cursor 

until the highlight bar is on Lines and release the button. 

• 	 Place the cursor near the center of the screen and press the Selection 
button. If you make a mistake at any point press the Menu (right) 

button to abort and start over. 

• 	 Move the cursor. Notice a ghost line appears between the selection 
point and the current position of the cursor. This shows you where 
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Figure 4.1 Using the Line Tool. Line uses a ··glve one·· method of crearing lines. The end point of a line becomes 
the beginning o f rhe next line until you double click to end the sequence. In the example. making a square is 
done by clicking again until all four comers are defined. The square is then closed with the last line and a double 
click IS issued when the starting point IS reached. 
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the line will be when you complete the operation. You may also note 

the line seems to snap to intersections of the grid. This is because 

Grid Snap is turned on (more on this later). 

• 	 Pull the cursor 2 grid lines down and press the Selection button. 

• 	 Move the cursor again. The rubberband line now extends from the 
second point. This is known as a "give one" method of creating lines. 
The ending point for the last line created becomes the beginning point 
for the next line. 

• 	 Move the cursor 2 grid lines to the right and press the Selection button. 

• 	 Move up 2 grid lines and press again. 

• 	 Close the square by moving the cursor back to the starting point. To 
end the line making process press the Selection button twice in rapid 

succession (double click). There should now be a 2 X 2 square in 

the color you selected on the screen. 

Lines are a principle tool in creating drawings, but some of the other 

tools can be used to perform functions similar to the one above. For 
example, Rectangles and Polygons can both create the square shape 
easier than Lines. 

Drawing a square with Rectangle: 

• 	 Select Rectangle from the Tools menu. 

• 	 Move the cursor near the first square and press the Selection button. 

• 	 Move the cursor down and to the right. A ghost frame will appear 
showing the rectangle. 

• 	 When the frame is a 2 X 2 square press the Selection button. A square 
like the first will appear. 
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Figure 4.2 Using the Rectangle Tool. A square like the one made above can C€ made easier with Rectangle. To 
use the tool, first selea it from the Tools menu, Place the cursor on the first comer and click. Now drag the cursor 
to the opposite comer. A ghost square appears showing what the objea Will look like when the operation is complete. 
\,\/hen the square is a 2 x 2 click the Seleaion button again 
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The Polygon command is similar to Rectangle. It lets you create multi

sided shapes quickly. After the first two points are chosen, two 

rubberband lines are attached to the two end points. you create the 

polygon by "stretching" these lines into the shape you want. 

If you follow this tutorial step by step the end result will be a basic 

office layout. The next step details llsing the Polygon function to create 

a desk with a return (an L shape). 

Create an L shape with Polygon: 

• 	 Select Polygon from the Tools menu. 

• 	 Place the cursor near the center but give yourself room to make the 

shape. Press the Selection button. 

• 	 Move the cursor down 2 grid lines and press the Selection button. 

• 	 Move the cursor to the right 4 grid lines and press the Selection button 
again. The polygon will begin to take shape. Notice the Polygon 

command creates an object that is already closed and you simply pull 

it into shape. 

• 	 Move the cursor down 4 lines and press the Selection button. 

• 	 Move to the right 3 lines, click, and then up 6 lines and double click 
(2 rapid presses of the Selection button) to end the shape. If you 

pressed once to many times a new polygon may be started from the 

pOint. Press the Menu button to cancel it. 

The lines used to build shapes can be made in a variety of ways. The 

thickness (weight) and pattern can be adjusted for each object created. 

Those already created can be changed to other Weights and patterns. 

There are 3 weights for lines (single, double, and triple width) and 

7 patterns ranging from solid to dotted. 
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Figure 4.3 Using the Polygon Tool. Odd shapes can be made either With the Une tool as detailed ear1ier or with 
Polygon. A polygon is a closed o~ea you pull into the shape you want. In the example an L shape is created 
by moVing to each point. clicking on it. and moving to the neX! point. The sequence is finished by double clicking 
on the last point. Notice that with Polygon the last line is already drawn for you. 
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Figure 4.4 Creating the Walls. The walls in the drawing are made with a thicker line. To change the thickness 
of the line selea Une Weight from the Opions menu and choose the trrple line weight from [he submenu:' With 
the Une tool draw tvvo mirrored L shapes as above Notice the horizontal lines are thicker [han the vertical ones. 
This is because there are more horizontal pixels so verncal lines appear squeezed. On a ploner both lines are the 
same thickness. 
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In the tutorial it's time to create some walls for the office layout. 
A typical diagram would show the walls with a thicker line than the 

one used to create things like desks. 

To adjust the line weight and draw some walls: 

• 	 Select Line Weight from the Options menu. A sub-menu box will open 
to the right displaying the 3 different line weights. 

• 	 Move the cursor until it is on the thickest line (triple weight) and 
release the button. 

• 	 Select Line from the Tools menu. 

• 	 Move the cursor to the upper left corner of the window and choose 
a starting point for the wall. 

• 	 Move to the upper right corner and click again. 

• 	 Move down halfway and double click to end the wall. 

• 	 Now move down 3 grid lines to leave space for a door and start another 
wall like the one above (down to the lower right corner and back 

to the left to end on the same line). 

• 	 Now draw 2 short lines, one from each end wall on the left. Leave 
a gap between them of about 8 grid lines. This will be a window. 
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Changing the line pattern and clt"awing a window: 

• 	 Select Line Pattern from the Options menu. A sub-menu box will open 
to the right displaying the different line patterns. 

• 	 Move the cursor until the dotted line pattern is highlighted and release 
the Menu button. 

• 	 Select Line Weight from the Options menu. A sub-menu box will open 
to the right. 

• 	 Choose the single line weight. 

• 	 Now draw a line across the gap at the end of the office. Presto! An 
office with a window, a desk, 2 filing cabinets, and no door. 

Some of the other shapes which can be made in Draw include arcs 
and circles. Arcs are made by first choosing the center point and then 

defining the radius. From these two points Draw will create a 360 

degree arc that is shortened by moving the mouse to get the arc you 
want. In the example an arc can be used to show the clearance needed 
for a door. 
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Making an arc and a door: 

• 	 Select Line Pattern from the Options menu and choose the solid line 
again. 

• 	 Now move to the point of the bottom door opening on the right and 
press the Selection button. 

• 	 Moving at a 45 degree angle from the wall draw a line 2 grid squares 
across and double click to finish the line. You should now have a 

door standing open. 

• 	 Select Line Pattern from the Options menu and choose the dotted 
line. 

• 	 Select Arc from the Tools menu. 

• 	 Place the cursor on the same point where you started the door and 
press the Selection button. 

• 	 Move straight up to meet the other wall and press the Selection button 
again. A ghost circle will appear with its center at the first point. 

• 	 Now move the cursor to the left. The circle will shrink to just the 
arc forming between the second selection point and the cursor. 

• 	 Move the cursor until it reaches the door and press the Selection button. 

All of the steps so far have been using the left side of the Tools menu. 

The right side of the menu lets you change or manipulate the objects 

on the left. For example the two squares created earlier are going 

to be filing cabinets. Right now they're sitting in the middle of the 
office. They need to be moved, say to the front against the wall. 
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Figure 4.5 Making a Door. MdJng the door to the example is an easy step. The line pattem IS set to solid and 
the Tools option is Une. First the bottom door jam is chosen. Next a line is drawn at a 45 degree angle into 
the office 2 gnd lines long. Notice the darted line pattem used for the window. There are 7 different line partems 
In Aegis Draw. 
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Figure 4.6 Using the Arc Tool. The arc In the example IS used for displaying the sw ing of the door It is created 
by choosing a darted line pattem and the Arc command from the Tools menu. The bortom door jam is used 
for the First POint This is the center of a circle from which the arc w ill be cut The cursor is then moved to the 
opposite door jam and that point chosen. This deFines the radius of the circle. LaSt the cursor IS moved to the 
left until it reaches, the door. This is the last point. A ghost arc appears showing what the shape will look like 
when it is complete. 
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To move an object: 

• 	 Select Drag It from the Tools menu. This works like any other tool. 

Until you change to another tool you are going to move any object 

you select. 

• 	 Place the cursor on the border line of one of the squares. To select 

an object in Draw, always place the cursor on one of the border lines 

of the object. Clicking in the center of the square will have no effect 

since Draw only sees the object as fou~ lines not as a square. 

• 	 The square will appear highlighted when selected. Now move the 
cursor. The highlight frame of the square will follow it. 

• 	 Place the frame near the front of the office. When it is in the right 
position press the Selection button to put the object down. The square 

will be erased and redrawn in the new position. 

• 	 Move the other square near the first. 

One of the other tools that's very handy is Clone. This lets you make 

copies of objects with just one command. For the example, another 

desk would be nice. 

To make a copy ofan object: 

• 	 Select Clone from the Tools menu. 

• 	 Place the cursor on a line of the desk shape and press the Selection 

button. A frame appears around the desk when it is selected. 

• 	 Move the cursor to one side. The frame will follow the cursor. 

• 	 When the frame is clear of the first desk press the Selection button 
again. A second desk will be drawn inside the frame area. 
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Figure 4.7 Using the Clone Tool. Clone creates copies of objects and allows you to move them about the drawing. 
A copy of the L shape is used to demonstrate thiS. The object IS selected by choosing one of its borders. Placing 
the cursor inside the object Will not work as AegiS Draw can only recognize an object when the cursor is on 
the border A frame will appear around the object when It is selected. The cursor is moved (the frame follows 
it) to the location for the copy and the Seleaion button is pressed again to end the operation. 
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Figure 4.8 Using the Rotater Tool. Rotate allows you to adjust the angle of objects as they appear in a draWing 
As an example of thiS the object just created w ith Clone is rotated. To rotate an object. first select it (a frame 
appears when it is selected). chen move the cursor to get che right alignment. The frame Will respond to the movements 
of the cursor lil/hen the frame shows the right alignment press the Selection button. 
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One more feature and we 'll call this part of the tutorial complete. 

Another useful way to manipulate objects is to spin or rotate them. 

The Rotater tool provides this function. In the office diagram one of 

the desks needs to be rotated and both moved . 

To rotate an object: 

• 	 Select Rotater from the Tools menu. 

• 	 Place the cursor on a line of one of the desks and press the Selection 
button. A frame appears around the desk when it is selected. 

• 	 Move the cursor to one side. The frame will spin on its axis as you 
move the cursor. Moving the cursor further away from the frame will 

give you more control of the rotation. 

• 	 Rotate the frame 90 degrees from its original position and press the 

Selection button. The desk will be erased and redrawn in the new 

position. 

• 	 Now use the Drag tool to move the desks into spots near the front 
of the office. 

If you want to continue this tutorial in the following chapters now 

would be a good time to save the drawing in case you need to quit 

at some point. This way you can come back to it to finish. 

To save the drawing: 

• 	 Select Save As from the Project menu. A sub-menu box will open 
to the right displaying the different file types. 

• 	 Move the cursor until Drawing is highlighted and release the Menu 
button. The storage requestor will be displayed. 

• 	 Click in the edit box labeled File. Type in the name of the drawing. 

-~ 
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• 	 When the name is correct select the OK button. The file will he saved 

in the Drawing directory under the name you gave it. 

To load the file back in: 

• 	 Select Open from the Project menu . The storage requestor will be 

displayed. 

• 	 The name of the file should be listed in the scrolling window in the 

center of the requestor. 

• 	 Place the cursor on the name and press the Selection button . The 
name will be loaded into the File edit box. 

• 	 When the name is correct select the OK hutton. The drawing will 

be loaded into the active window. 
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5 Editing 

The features under the Edit menu are similar to the edit functions 

on the right side of the Tools menu. The difference is the Edit commands 

work on all the objects in an area. So performing a rotation for example 

changes everything in the selected area at the same time. 

The three main commands under the menu are Cut, Copy, and Paste. 

These commands allow you to lise an area of memory known as the 

clipboard to change the drawing. When one of these functions is 

performed all of the objects in the area are moved to or from the 

clipboard. A Cut command will erase all of the objects in the selected 

area and move them to the clipboard. A Paste command can then 

be used to move them from the clipboard to any point in the drawing 

or even to another drawing or window. The Copy command performs 

like Cut except the objects are not removed from the drawing, they 

are only copied into the clipboard . 

In the example the two filing cabinets will be moved as a unit. 

• Select Cut from the Edit menu. 
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• Place the cursor a full grid line above and to the left of one of the 

cabinets and press the Selection button. 

• Move the cursor 1 grid line below and to the right of the other cabinet. 
A selection frame will appear around the squares. Be sure the frame 

encloses both cabinets. 

• Press the Selection button. The squares will be erased from the screen. 

'-....0• Select Paste from the Edit menu. A frame will be attached to the 

cursor. This is the contents of the clipboard. 

• Move the frame to the back of the office and press the Selection button. 

The squares will be redrawn. 

• Now choose Paste again from the Edit menu. The frame will reappear. 
The contents of the clipboard is still there. It will not be changed 
until another Cut or Copy command is performed. Press the Selection 
button again so you have 4 squares altogether. 

In addition to these commands is another handy function, the eraser 
(detailed in Chapter 10). The eraser uses the same selection frame 
process. Once an area has been chosen all the objects entirely inside 
the frame will be removed from the drawing. Commands like this raise 

a problem. What happens if you make a mistake. The Undo command 
is there for the inevitable slip. Most of the commands in Draw can 

be undone once they are performed. The command option in the menu 
is shaded anytime it cannot be used or there is nothing to Undo. 

Try an Undo. 

To Undo an action: 

• Select Paste from the Edit menu. This will be the action to remove. 

• Paste the object on the drawing. 
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Figure 5.1 Using Cui and Pasle. The functions under Edit menu perform actions similar to the edidng tools but 
they work on all of the objects in a selected area. The Cui, Copy, and Pasle functions use an area known as 
the clipboard. A Cui command will remove the objects in an area and store them there. Copy places a copy 
of the objects in the clipboard while Pasle is used to move the contencs of the clipboard into a drawing. Areas 
may be moved from one drawing to another thiS w ay. 
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Figure 5.2 Using Rolale. The Rolale function is like the Rolaler command under the Tools menu. Instead of working 

with only one object though it adjusts all of the objects in a chosen area. In the example the Rling cabinets are 
rotated together. 
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Now select Undo from the Edit menu. The drawing will be redrawn 

with the last paste action removed. 

Now it's time to rearrange the tiling cabinets that have been moved 

to the back of the office. Under the Modify command are a series 

of sub-functions you can use to do this. To move the cabinets from 

the middle of the floor they need to be turned sideways and moved 

against the wall. 

To rotate all the objects in an area: 

• 	 Select Modify from the Edit menu. A sub-menu box will open to the 

right showing the different Modify commands. 

• 	 Move the cursor until the Rotate command is highlighted and release 
the Menu button. 

• 	 The command works like the other Edit commands now. Move the 
cursor to an area above and to one side of the cabinets and press 

the Selection button. 

• 	 Move the curSOr to the opposite corner completely enclosing both 

cabinets and press the Selection button. 
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Now the function works in the same manner as the Rotater under 

Tools. Move the frame until the shapes are rotated 90 degrees and 

press the Selection button. 

Once both sets of cabinets have been rotated , move them flush with 

the wall. Obviously this same task could have been performed a number 

of ways. Because the shapes were so simple, the Drag It command 

could have been used to move them one at a time against the wall, 

but when an area is filled with shapes or it needs a slight angling 

the Modify command is perfect. 

Zoom and Zoom Windows 

The Zoom option is one of the more powerful capabilities of Draw. 

It lets YOll move into your drawing to an almost infinite level. It is 

not like a "Fat-Bits" operation in a paint package where the pixels 

get big so YOll can see them better. The pixels always stay the same 
size but objects get bigger as YOll zoom in on them. 

In the example the filing cabinets could use some names. Time to 

zoom in on them and add some tex t. 
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Using Zoom and Text: 

• 	 Select Zoom from the Display menu. A sub-menu box will open to 
the right showing the different options. 

• 	 Move the cursor until In is highlighted and release the Menu button. 

• 	 Place the cursor above and to the left of the filing cabinets and press 
the Selection button. 

• 	 Move the cursor to the opposite corner. A ghost frame will appear 
showing the area to zoom in on. This will be the display in the window 

when the operation is complete. 

• 	 When the frame is correct press the Selection button again. The screen 
will be redrawn at the new level. Notice the rulers and grid have 

changed to reflect the new level of display. 

Now to put a name on each of the cabinets. The Text command is 
one of the Tools. When you activate it, a requestor is displayed. In 

the requestor is an edit box for the text you will use. 

To add text: 

• 	 Select Text from the Tools menu. A requestor is displayed. 

• 	 Click inside the edit box with the Selection button. 

• 	 Enter the text "File A" with the keyboard . 

• 	 When the text is correct press RETURN or select the Label button 
on the requestor. 

• 	 Move the cursor until it is 1 grid line from the inside left of the left 
most cabinet and press the Selection button. 
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Figure 5.3 Using Zoom and Text. To r;erform the next step in the tutorial. twO different funaions are used. The 
first, Zoom. is a magnify feature which allows you to work in increasing levels of detail. To Zoom In you selea 
the command from the Display menu and then define the area similar to the way you choose an area for editing. 
The view in the window is changed to magnify the area. looming in on the part of the office with the filing 
cabinets allows you to \I\IOrk on them in detail. The next step is to label them with text. The Text funaion uses 
a sr;ecial type of font which allows you to size or distort the label With great flexibility and still maintain a high 
level of clarity. A text label is like any other objea. It may be moved, rotated, resized, or edited. Once the text 
labels are added to the cabinets the regular display may be retumed with the Full Display command. 
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• 	 The command works similar to the Rectangle tool. Move the cursor 
to the opposite corner to make a rectangle. The text will be printed 
inside this space. The frame can be made to any height and width 

to distort the text as you need. In this case move the cursor 1 grid 

line from the inside right of the cabinet and 4 grid lines down. 

• 	 Press the Selection button. The text will be printed in the space. 

• 	 Now select Text again. The requestor will be presented. 

• 	 Click inside the edit box to activate it. Use the backspace key to delete 
the "An and replace it with "B". 

• 	 Press RETURN or use the Label button to exit the requestor. 

• 	 Label the next cabinet. Repeat the process to name each cabinet with 
successive letters. 

• 	 Once all of the cabinets are labeled select Full Display from the Display 

menu to return to the original view. 
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6 Advanced CAD 
Operations 

A great feature of Draw is the ability to create parts. A part is a collection 

of shapes grouped together to form a single unit. This means once 

the individual objects are a part the commands under the Tools menu 

can be used to manipulate them. 

In the example, a water cooler can be used to demonstrate making 

a part. First, make the cooler. 

Making a water cooler: 

• Select Zoom and then In from the Display menu. 

• Choose an area that is 4 grid lines high and 6 wide. 

• Select Rectangle from the Tools menu. 

• Select a solid line pattern from Line Pattern under the Options menu. 

• Draw a 6 by 6 grid line square near the center of the screen. 

• Select Circle from the Tools menu. 
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• 	 Place the cursor in the center of the square you just created and press 
the Selection button. 

• 	 Move the cursor toward a line of the square. A ghost circle will appear. 
This will be the water tank of the cooler. 

• 	 When the circle almost touches the lines of the square press the 
Selection button. 

• 	 Choose Text from the Tools menu . The text requestor will appear. 

• 	 Enter "WC" for water cooler in the edit box and press RETURN or 
use the Label button when complete. 

• 	 Place the text inside the circle. 

• 	 Choose Full Display from the Display menu. You should now have 
a water cooler that is a little larger than one grid square in your full 
display drawing. 

Now to make the separate objects into a single unit. 

To create a part: 

• 	 Choose Group from the Edit menu . This command works like the 
other functions under the Edit menu. You create a frame around the 

objects you want to group together. 

•	 . Place the cursor above and to the left of the water cooler and press 
the Selection button. 

• 	 Move the cursor below and to the right of the water cooler and press 
the Selection button again. The part requestor will appear. Notice the 
last text you entered (WC) is in the edit box. 
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Figure 6.1 Making a Water Cooler. Three objects are brought together to make a water cooler. Thl" first IS a...,~....._____ 
x 6 gnd line square which represents the base of the cooler. The next ogea added is a CIrcle with its center located 
in the middle of the square. This is the water tank of the cooler. Last a label of ·we iwater cooler) IS added 
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Figure 6.2 Making a Part. The three ogects used to create a water cooler can be grouped together to create a 
part. The advantage of making parts is twofold. First. ir saves memory if you are going ro use rhe part repearedly. 
and second ir saves rime because a Single mouse aCtJon will create rhe entire part. To make a part. selea rhe 
Group funaion from rhe Edit menu and selea rhe area with a frame. 
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• 	 The name you want to give to the part should be entered in the edit 
box. Since "WC" is a good abbreviation for a water cooler choose 
the Name button to accept it as the name for the part. The name 

and the part have now been entered into the "In Stock" list for this 

drawing. 

Now that the part has been created it can be edited and changed 

like any other object. This is how to create symbols for any object 

you use a lot in your drawings. Not only can the object be manipulated 
like any other object but it can be created like one as well. 

Using a part: 

• 	 Select Part from the Tools menu. The part requestor will appear with 
a list of available parts. In this case there is only one (WC). 

• 	 Place the cursor on the part name and press the Selection button. 
The name will be loaded into the Part edit box. 

• 	 Choose the OK button to accept this part. 

• 	 The command now works like any other Tools function. You are 
creating this part until you change tools. Press the Selection button. 

A frame will appear attached to the cursor. This is the water cooler. 

• 	 Move the cooler to the front of the office and press the Selection 
button again. The water cooler will be drawn. Pressing the Selection 

button now will bring up the frame for another cooler. This will 

continue until you choose another part or a different tool. 

• 	 Try dragging and other editing features of the Tools menu on the 
water cooler. Normally these commands would only affect the square, 
circle or text objects individually. 

Once a part has been created you may want to edit it. This is done 
with the Explode command under the Tools menu. It breaks a part 
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back into its individual objects. This way additions or changes can 

be made. The objects must be regrouped after the changes and given 

a name. To explode a part choose the command, select the part 

(highlighted when selected), and press the Selection button to accept. 

The objects are then separate. 

Another important feature of Draw is Layering. This allows you to break 

a drawing up. For example, in the office layout all of the electrical 

symbols could be placed on a single layer separate from everything 

else. This way a view could be generated showing only the electrical 

without any other confusing objects. 

Draw lets you create 250 different layers and show any number of 

them at a time. There are 2 parts to this function. The first lets you 

choose the active layer to put obje..:ts on and the other is for selecting 

the layers to be shown. 

First , choose a layer to put all of the electrical objects on. 
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To choo~e the active layer: 

• 	 Select Layer from the Preferences menu. The layer requestor will 

be presented. 

• 	 The currently active layer (the one everything else you've made is 

on) is AO. Place the cursor on the intersection of A and 1 and press 

the Selection button. It will darken to indicate it is selected. 

• 	 Choose the OK button to exit the requestor. 

Now that the active layer has been changed the objects to put on 

the 	layer can be created. The next few steps quickly outJine making 

the electrical outlets and lights in the office. 

.-, 
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Figure 6.3 Selecting the Active layer. Draw supports a mUlti-layer enVIronment. Tnere are 250 li'lyers available for 
use. IMlen objects are created they are aSSigned to the aGive layer. The aaive layer is chosen by seleGing Layer 
from the Preferences menu. Once the layer requestor is presented clicking In the cell created by the Interseaion 
of a lener and number will selea that layer as aalve. The default layer IS AD. 
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Figure 6.4 Creating the Electrical layer. All of the overhead lights and wall outlets in the office example are assigned 
to a different layer. This is done by changing the acive layer before the ogects are created. Later the drawing can 
be Viewed or ploned with or without the elearical layer by choosing the layers to display with the Layers. Shown 
command. 
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To make the eledrical objects: 

• 	 Select a new color for these objects. Choose the dark blue from the 
Color menu. 

• 	 Select Rectangle from the Tools menu and make a very small rectangle , 
This will represent a wall outlet so make it the appropriate size. 

• 	 Next, make a larger rectangle. This will represent overhead fluorescent 
lights. 

• 	 The next step will require the Data Snap and Grid Snap functions 
to be turned off. The functions have been on through the tutorial 
so far. Select Data Snap from the Preferences menu. A sub-menu 

box will open to the right. Choose Off from this box. Repeat this 
with Grid Snap. 

• 	 Select Clone from the Tools menu. 

• 	 Select the small rectangle. Move the frame to a point near the front 
desk and place it in the wall. Press the Selection button. Repeat this 
step and place outlets around the office. Don't forget the water cooler. 

Now Select the large rectangle and repeat the process above except 
place the lights in a regular overhead pattern. 

• 	 Select Erase from the Edit menu and remove the originals from the 
drawing. 

Now the drawing is beginning to become cluttered. Here's the beauty 
of layering; choose to display only the first layer and all of the electrical 
will disappear. 
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'1'0 choose the display layers: 

• 	 Select Layers Shown from the Display menu. The layers requestor 
will be presented. 

• 	 Place the cursor on the intersection of A and 1 (the electrical layer) 
and press the Selection button. It will lighten to indicate it is no longer 
active. 

• 	 Choose the OK button to exit the requestor. The display will change 
to show the drawing without the electrical. 

One last detail and the basic office layout will be complete. All it 

needs are a few dimension lines. Draw has an easy solution to this, 

automatic dimension lines. 
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To create dimension lines: 

• 	 .Turn the Data Snap option back on. To do this select Data Snap 
from the Preferences menu. Choose the sub-menu option On. 

• 	 Select Dimension from the Tools menu. This function operates like 
the Line command. 

• 	 Place the cursor on the same grid line as the top wall and press the 
Selection button. 

• 	 Move the cursor to the same grid line as the bottom wall and press 
the Selection button again. A dimension line will be drawn between 

the two points. 

• 	 Try placing a few other dimension lines on your drawing. The function 
will work at any angle or distance. 

Once a drawing is complete the next step is to print or plot it onto 
paper. 

"-'. 
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Figure 6.5 The Finished Drawing. Once a drawing is complete it may be printed or plotted on paper. Printing the 
drawing will produce the current view of the window. Sending the drawing to a plotter will produce the drawing 
regardles'S of the view [zoomed. etc.) Portions of a drawing can be plotted by use of the Fonnat command. If 
the grid lines are tumed on trey will be printed or plotted with the drawing. 
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To plot yow' drawing: 

v 

• Be sure the plotter is turned on and connected to the computer. 

• Select Plot from the Project menu. Draw will attempt to create a plot 
file on disk. If there is enough room the program will send all of 

the commands to this file first and then execute the plot from there. 
This will free up Draw sooner so you can use it while the plot is 

running. 

To print your drawing: 

• Be sure the printer is plugged in and turned on. The Preferences menu 
on the Amiga should be set properly as Draw will print directly to 

there. 

Select Print from the Project menu. 
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CHAPTER 


The Working Environment:

7 Windows, Grids, and 
Rulers 

The working environment of Aegis Draw consists of a desk top on 

which work areas called "windows" are manipulated. The windows 

have gadgets for adjusting their size, position on the screen, portion 

of the drawing they display, and for removing them from the screen. 

There is a starting window that is always present. Windows also make 

use of rulers and grids which can be turned on or off independently. 

Rulers show the exact position of objects in a drawing relative to the 

format you have chosen. They occupy the left and lower portion of 
a window when active. 

The grid is used like the lines on a piece of graph paper to position 

objects and shapes accurately. Like rulers, they can be turned on or 

off in each window. 

Windows 

Each window can hold a separate drawing or different views of the 

same drawing. You may open as many windows as you have memory 

for. Those using Draw with 512K Amigas will need to be careful since 
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each window uses 64K of RAM when opened. Draw will limit you 

to a number of windows it considers to be safe. On a 512K Amiga 

you will be allowed to open two windows. Draw will take advantage 

of any additional memory you have installed and allow more windows 

to be used. 

The right and bottom borders of each window house the scroll controls. 

Inside each border is a slider. The sliders change size in proportion 

to the amount of drawing being displayed in the window. So, if the 

window displays the entire drawing, the sliders will be full size. If 
the window displays half the drawing the slider takes up half the border. 

Scrolling horizontally through the drawing simply involves grabbing 

and dragging the slider in the bottom border in the direction you 

want to go. When the mouse button is released the view in the window 

changes. To scroll vertically use the slider in the right border. Small 

scrolling adjustments can be made by clicking on the arrow buttons 

located on each end of the slider controls. These can also be used 

when you are zoomed in too far for the sliders to be accurate. 

The windows may be moved about on the screen by dragging the 

top border, or resized with the gadget in the bottom right corner. 
The window will retain the same view after a size change with the 

image enlarged or reduced to fit the new size. Draw uses the width 

of the drawing being displayed as a "baseline". If you change the shape 

of the window ( narrower/ wider) , Draw will maintain the correct aspect 

ratio of the drawing. 

The background color for each active window can be changed to any 

of the colors in the color palette. This function is discussed in detail 

later under Set Color. 

To scroll through a drawing: 

• 	 Click on the arrow gadget located in the bottom and right borders. 

You may also click in the border itself or drag the indicator to the 

relative position in the drawing you want to see. To drag the indicator, 

.~ 
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place the cursor on the indicator (the dark portion of the border) 

and hold the button down. It will highlight to indicate it is selected. 

Now drag the cursor to the portion of the drawing you want and 

release the button. 

To re!iize a window: 

• Place the cursor on the resize gadget (extreme lower right corner 
of the window) and hold down the Selection button. A ghost frame 

will appear. 

• Drag the cursor until the ghost frame is the size you want and release 
the Selection button. 

To close a window: 

• Click in the close box (extreme upper left corner of the window). 
If this is the only window displaying a particular drawing, you will 
be prompted to Kill EXisting Drawing?, since Draw will clear the 

drawing from memory. 

To bring a window to the front: 

Click on the Window Forward gadget (extreme upper right corner 
of the window). It's the one with the clear window in front. 

To move a window to the back: 

• Click on the Window Back gadget (extreme upper right corner of 
the window). It's the one with the solid window in front. If you want 

to draw in a different window, you should click on the title bar in 

order to make the window active. 
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Grid 

Grids are used for accurate positIOning of objects on the drawing. 

The grid size, line pattern, and color can all be adjusted individually 

in each active window. Grids can also be turned on or off during 

drawing. When you resize a window or perform a zoom, the grid is 

automatically set to a logical value. You can override this manually 

with the Grid Size item in the Options menu. 

Another feature is Grid Snap. When active this option "snaps" or lines 

up objects created to the nearest intersection of the grid. This allows 
you to create shapes with a high degree of accuracy. Grid Snap is 

independent of the display of the grid. 

Adjusting the grid color is discussed under the Set Color command. 

Grid On/ Off 

To turn the grid on or off for the active window select Grid Onl 
Off from the Display menu. 

Grid Pattern 

The same line patterns available for creating shapes can be used for 

the grid lines. There are 9 different patterns to choose from. The default 

line pattern is solid. 

To change the grid pattern in the active window: 

• 	 Select Grid Pattern from the Options menu. A sub-menu box will open 

to the right of the selection displaying the available line patterns. 

• 	 Drag the cursor until it highlights the line pattern you want and release 
the Menu button. The grid pattern in the active window will change 

to the new selection. 
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Grid Size 

Grid Size allows you to change the width between lines in the grid. 

Both the horizontal and vertical lines may be set independently. Grid 
size is reset when you resize a window or use Zoom. This is to prevent 
the lines from getting "bunched" together. 

To adjust the size ofthe grid in the active window: 

• 	 Select Grid Size from the Options menu. A requestor will open on 

the screen. 

• 	 Enter the new values in the edit boxes and select the OK button to 
accept the new values. Choose Cancel to back out of the operation 

with no changes made. 

Grid Snap 

Grid Snap will override many of the other functions in Draw such 
as Data Snap. Data Snap will automatically connect two lines if they 

are close together when created. If Grid Snap is turned on it will 
override this option and force the line to the nearest grid intersection 
instead. 

The grid intersections are absolute values. In some cases it is impossible 
to get a perfect value to the highest precision because the resolution 
of the screen will not support it. For example, in a full display placing 
the cursor at the y= 10, x= 12 intersection may produce a y value of 
10.0025 and an x value of 12.0345. Moving the cursor about produces 
changes in the numbers but the absolute value of 10.0000 and 12.0000 

cannot be achieved without using the Zoom function. This moves in 

to a level where those numbers can be supported by the screen. The 
Grid Snap option automatically sets the grid intersections to these 
absolute values, so shapes created with this option on are precise to 
the highest level. Rounding can also be used to eliminate some of 

this roundoff error by limiting the fractional portion to one decimal 

place. 
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To turn Grid Snap on or off in the active window: 

• 	 Select Grid Snap from the Preferences menu. A sub-menu box will 
open to the right displaying the current state. The item check marked 

is the active condition. 

• 	 Drag the cursor until it highlights the selection you want (On or Off) 
and release the Menu button. If you open the menu again the check 

mark should be next to the option YOll chose. 

Repaint Grid 

This option quickly redraws just the grid pattern in the active window. 

This is handy when working on large drawings. Rather than waiting 

for an entire drawing to be redrawn just to refresh a portion of the 

grid you may have erased, it 's faster to use Repaint Grid. 

To refresh the grid in the active window: 

• 	 Select Repaint Grid from the Display menu. 

Rulers 

The rulers display your position relative to the entire drawing. You 
may set the units the rulers will display. Both Metric and English 

standards are supported. 

The rulers occupy the left and bottom borders when active. They cannot 

be repositioned but the view of a window can be adjusted to place 

a ruler anywhere on a drawing. The start and end points of the ruler 
can be set with the Format command. 

The color of the rulers may be changed with the Set Colors command. 
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Rulers On/Off 

To turn the rulers on or off in the active window select Ruler On l 
Off from the Display menu. 

Units 

Units allow you to set the type of ruler display you see on the screen. 

English units set the ruler to have divisions of 1/2, J14 , I/H etc.. 

Metric units will divide the ruler into 1/ 1O's, 1/ 1OO's, etc. The actual 

numbers in the ruler ret1ect the real coordinates in the drawing. They 

can represent any "real world" units you work in. 

To select the type of units displayed on the rulers: 

• 	 Select Units from the Options menu. A sub-menu box will open to 

the right displaying the current state. The item check marked is tbe 

active condition. 

• 	 Move the cursor until the type YOll want is highlighted and release 

the Selection button. 

Set Color 

Each window may have its own color arrangement. The background, 

grid, and rulers can all be adjusted individually. Any color in the current 

color palette may be used. 

Background 

To change the background color in the active window: 

• 	 Select the t1esired new color from the Color menu. 

• 	 Select Set Color from the Display menu. A sub-menu box will appear 
to the right of the selection. 

• 	 Drag the cursor until it highlights Background and release the Menu 

button. The background will change to the new color. 
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Grid 

To change the grid color in the active window: 

• 	 Select the desired new color from the Color menu. 

• 	 Select Set Color from the Display menu. A sub-menu box will appear 

to the right of the selection. 

• 	 Drag the cursor until it highlights Grid and release the Menu button. 

The grid will change to the new color. 

Ruler 

To change the ruler color in the active window: 

• 	 Select the desired new color from the Color menu. 

• 	 Select Set Color from the Display menu. A sub-menu box will appear 

to the right of the selection. 

Drag the cursor until it highlights Ruler and release the Menu button. 

The rulers will change to the new color. 

Zoom 

Zoom lets you get in and work in detail on a drawing. There are three 

ways of using this option: zooming in on a drawing in the active window, 

zooming out, and creating a separate window for the zoom. This last 

feature gives you the ability to see both the enlarged version and the 

original at the same time. Both windows will display any changes you 

make in either window. The level of zoom available is nearly infinite 

and as you zoom in or out, the rulers will adjust their display accordingly. 
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In 

Zooming in is easy. You just choose the area you want to see in detail 

by placing a frame around it. The window then changes to display 

the contents of your frame enlarged to t1l1 the entire window. 

To Zoom In on an area in the active window: 

• 	 Select Zoom from the Display menu. A sub-menu box will open to 

the right with the available options. 

• 	 Drag the cursor until In is highlighted and release the Menu button. 

• 	 Place the cursor on one corner of the area you want to enlarge and 

click the Selection button. 

Move the cursor to the opposite corner of the area. A rubber band 

frame will appear between the first point and the cursor. When the 

frame encloses the area you want click the Selection button again. 

Out 

The Zoom Out option works in reverse of Zoom In. It performs a 

reduction of the image. This is done by doubling the area in the window. 

Each use of the function will double the display space both vertically 

and horizontally. Once the normal display area is achieved, the function 

will have no effect. 

To Zoom Out of a drawing in the active window: 

• 	 Select Zoom from the Display menu. A sub-menu box will open to 

the right displaying the available options. 

• 	 Drag the cursor until it highlights the Out option and release the Menu 

button. 
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Using this version of the command will create a separate window to 

display the zoomed area. The original window is not affected. Any 

editing done in either window will be displayed in both windows. 

If Draw decides there isn't enough memory for a new window, you 

will get the message Insufficient Memory. 

To create a separate window to display a zoomed area: 

• 	 Select Zoom from the Display window. A sub-menu box will open 

to the right showing the available options. 

• 	 Drag the cursor until it highlights the Window option and release 
the Menu button. 

• 	 Place the cursor on one corner of the area you want to enlarge and 

click the Selection button. 

• 	 Move the cursor to the opposite corner of the area. A rubber band 

frame will appear between the first point and the cursor. When the 

frame encloses the area you want click the Selection button again. 

Full Display 


Once you have zoomed into a drawing the time will come when you 

want to return to the original display. The Full Display command 

performs this function. It backs you out of any number of zooms (In 

or Out) you have performed. If you are already at the original display 

the function will have no effect except to refresh the drawing. 

To return to the original display: 

• 	 Select Full Display from the Display menu. 
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Crosshairs 

When active, the Crosshairs function attaches a set of rubberband 

Jines to the cursor. They extend vertically and horizontally for the 

full length of the window and cross at the center of the cursor. They 

may be used as an aid in lining up objects on the screen . 

When the Grid Snap function is turned on the crosshairs may seem 

to drag behind the cursor. This is because the crosshairs are snapping 

to the nearest grid intersection. This can be very useful as Grid Snap 

will effect all functions that read the cursor location off the screen, 

Crosshairs will show you "where you are" on the screen. 

To turn th e Crosshairs on or otf: 

• Select Crosshairs OnlOff from the Display menu. 

Numerical Display 

As an added aid to object placement Draw has a numeric display of 

the cursor position. When active the current x,y coordinates of the 

cursor are displayed in the menu bar. The coordinates are relative 

to the rulers and are accurate to the fourth decimal place. 

The x coordinate represents the horizontal ruler position and the y 
coordinate the vertical position. 

When using the numerical display you may note it is often next to 

impossible to get a reading where all the decimal places on both 

coordinates are zero. This is because that position is smaller than a 

pixel on the current screen. If you want to use exact measurements 

where all decimal places are zero, switch on Grid Snap. This automatically 

imposes a "snap" to the exact grid coordinate. If YOll want to get 

an exact position that won't appear, perform a Zoom In to the area 
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and try again. You can also change Grid Size or Set Rounding in 

the Options menu. 

To turn the numerical display on or off: 

• 	 Select Numeric Display from the Preferences menu. A sub-menu box 
will open to the right displaying the two options. 

• 	 Move the cursor until the option you want is highlighted and release 

the Selection button. 
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8 Tool Options 

Each of the tools used to create objects in Draw have options controlling 

their appearance on the screen. The color, thickness, and pattern of 

the line are all adjustable. Once a tool has been chosen as the active 

shape it uses the currently active values of these options. If another 

shape is chosen it will use the same options. 

There are 16 colors available in the 640 X 200 resolution mode of 

the Amiga. The color palette in Draw supports all 16 of these colors. 

The color slots in the palette can be thought of as ink wells. The 

color in each well can be adjusted to produce any of 4096 different 

colors available on the Amiga. Any object created with the ink of a 

well will change its color if you adjust the color of that well. 

The first 3 colors in the palette (dark blue, white, and black) are 

used by draw for the desktop, menu bar, and windows. Any adjustment 

of these colors will change the way Draw appears on the screen. For 

example, changing the white to black would render the menus 

unreadable. 
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Modifying the Color Palette 

The Modify Colors command under the Colors menu displays the color 

edit requestor on the screen. The requestor contains a color palette 

and several gadgets for adjusting the colors. The large block of color 

on the right of the palette is the currently active color. You change 

the active color by clicking on the color you want in the color palette. 

Below the palette are 3 slider controls for adjusting th e Red, Green, 

and Blue components in the active color. Moving a slider to the right 

increases the amount of red, green, or blue (depending on which slider) 

in the active color, while moving to the left decreases. 

When the requestor first appears, the RGB sliders have no affect. You 

must first choose a color before they will operate. 

There are also 3 buttons: OK, Cancel, and Reset. 

Ok accepts all changes made to the palette and returns to the regular 

drawing mode. 

Cancel erases any changes made to the palette during the current 

use of the requestor and returns to the regular drawing mode. 

Reset changes the palette back to the original colors it contains when 

Draw first starts up. 

To change the colors in the color palette: 

Select Modify Colors from the Colors menu. A requestor will appear 

in the center of the screen. 

• 	 Choose the color to change. The active color block will change to 

the color you chose. 

• 	 Adjust the RGB controls until the color is the one you want. 
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Figure 8.1 Modify the Color Palette. There are 16 different colors available in Draw The First three colors in the 
palette (numbered 0, I, and 2) from left to right at the top are used in the menus and requestors. The colors may 
be changed to any of 4096 different hues by use of the Modify Colors fUnction under the Colors menu. Selecting 
this command produces a requestor with the color palette three sliders and three buttons. On the right of the palette 
is a large block of color. This is the currently active color in the requestor. The sliders control the amount of Red, 
Green, and Blue in the color being changed. The OK button acceplS any changes made In the requestor and 
closes it. The Reset command changes the colors back to their default values, and the Cancel button exilS the 
requestor without keeping any changes. To change a color click on it in the requestor without keeping any changes 
To change a color click on it in the requestor palette. The active color block will change to that color. Adjust the 
RG.B. slider controls until the color is the one you want. Make other changes as you need then choose OK to 
accept the changes. 
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• 	 Click on the OK button to accept the changes you made. Use Cancel 
to hack out with no changes made. 

Line Weights, Patterns 

The lines used to create shapes are defined by their weight (thickness) 

and pattern. There are 3 line weights and 9 patterns available. The 

weights are single, double , and triple line thickness. The patterns range 

from solid to dotted. 

To adjust the line weight: 

Select Line Weight from the Options menu. A sub-menu box will open 

to the right showing the three weights availahle. 

• 	 Move the cursor until the weight you want is highlighted and release 
the Menu button. 

To change the line pattern: 

• 	 Select Line Pattern from the Options Menu. A sub-menu box will open 
to the right showing the line patterns to choose from. 

• 	 Move the cursor until the line pattern you want is highlighted and 
release the button. 

Filled and Outline Preference 

Shapes can be created either filled with a pattern or in outline form. 

This option is a preference which can be turned on or off. 'W11en turned 

on all shapes created will be filled with the current fill pattern. 

This option is also active when using the Color command from the 

Tools menu. 'W11en Filled is turned on, using the Color command to 
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edit an already existing shape will cause it to be filled. This is a good 

shortcut to use when creating a lot of shapes both filled and outline. 

Rather than switching the preference back and forth through the menu 

just create all the shapes in outline form and then go back with the 

Color tool to change the filled shapes. 

Not all shapes can be filled. Text, Arcs, and Dimensions cannot be 

filled. 

To change the Filled preference: 

• Select Filled from the Preferences menu. A sub-menu box will open 
to the right showing the two options (On,OH). 

• Move the cursor until it highlights the desired option and release the 
menu button. 

Fill Patterns 

Filled shapes are created with the currently selected fill pattern. There 

are 8 different patterns ranging from a solid fill to mesh weave. They 

are line patterns designed for use with plotters. 

To change the CUt'l'ent fill pattet'Jl: 

• 	 Select Fill Pattern from the Options menu. A sub-menu box will open 
to the right displaying the available patterns. 

• 	 Move the cursor until the highlight box is around the pattern you 
want and release the Menu button. 

8-5 



INSIDE AEG IS DRAW 

8-6 




CHAPTER 


9 Tools 

The shapes listed under the Tools menu are the basic building blocks 

for creating drawings. There are tools for drawing lines, rectangles, 
circles, arcs, polygons, freehand images, and text. There is also a tool 

for creating dimension lines that automatically display their numeric 

value. Another important feature is the ability to identify a group of 

shapes as a part. Once stored, a part can be recalled again without 

having to redraw the individual shapes. 

The shape tools all work in a consistent manner: choose the shape 

from the menu , place the cursor at the starting point for the shape, 

press the Selection button, move the cursor to the next point and 

press the Selection button again. Some shapes like polygons require 

more than two points for definition. fn this case the last step is repeated 

until the shape is complete and then the Selection button is pressed 

twice (double click) in rapid succession. Freehand works like a "pen", 

while you hold down the left button you are drawing a freehand line. 

To abort the creation of a shape at any time press the Menu button. 
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Line 

The line tool will allow you to create as complex a shape as you need. 

It uses a system known as "give one" which means each end point 

of a newly created line becomes the beginning point of the next line 
until you turn the tool off. This way a complex shape is just a series 

of points as you move to create it. 

If the Filled option is turned on, Draw will attempt to fill the shape 

you have created even if it has open sides. 

To draw a line: 

• 	 Select Line from the Tools menu. 

• 	 Place the cursor where you want the line to begin and click the Selection 
button. 

• 	 Move the cursor to where you want the line to end and click the 
Selection button again. If you want to create another line from this 
point move the cursor again. 

• 	 When the shape is complete double click the Selection button. 

Rectangle 

To draw a rectangle: 

Select Rectangle from the Tools menu . 

• 	 Place the cursor where you want one corner of the rectangle to be 
and click the Selection button. A ghost rectangle will appear attached 
to the cursor. 

• 	 Move the cursor to the opposite corner of the rectangle and click 
the Selection button again. 
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Polygon 

To ~reate a polygon: 

• 	 Select Polygon from the Tools menu . 

• 	 Place the cursor on the tlrst point of the polygon and click the Selection 

button. A ghost line will appear under the cursor. 

• 	 Move the cursor to the next point of the polygon and click the Selection 
button again. Continue this step for each point of the polygon. 

• 	 When the polygon is the shape you want, double click the Selection 

button. This will end the polygon create sequence. 

Freehand 

It is recommended YOLI lise freehand sparingly as it uses a lot of memory. 

Many shapes you would use freehand for can be made with line and 

the smoothing option. 

To create freehand shapes: 

• 	 Select Freehand from the Tools menu. 

• 	 Holel the selection button down and move the cursor. 

• 	 When the freehand line is the shape you want , let go of the Selection 
button. 

Arc 

To create arcs: 

• 	 Select Arc from the Tools menu. 
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• 	 Place the cursor on the center of curvature of the desired arc . 

• 	 Move the line until you get the desired radius and starting point for 

the arc. Click the Selection button to set the radius and starting point. 

• 	 Drag the arc until you reach the desired ending point. Arcs are drawn 

counter-clockwise in Draw. This corresponds to the cartesian coordinate 

system used in drawings. Click the Selection button to set the ending 

point of the arc. 

Circle 

A circle is actually a polygon with 72 points. If you arc connecting 

a line to a circle with Data Snap the line will connect with one of 

these points. 

To create a circle: 

• 	 Select Circle from the Tools menu . 

• 	 Place the cursor where the center of the circle is to be located and 

click the Selection button. 

• 	 Move the cursor away from the center. A ghost circle will appear under 

the cursor. 

• 	 When the circle is the size you want click the Selection button again. 

Text 

In Aegis Draw, text is handled in the form of labels. You create a 

label by entering text into an edit field and then placing it in the 

drawing. The text is created using a stroke font. A stroke font creates 

a letter by using the strokes that make up the character rather than 

reproducing a bit image. This creates a clear readable font at almost 

any size. 
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To create a text label: 

• 	 Select Text from the Tools menu. The text edit requestor wiiJ appear. 

• 	 Click inside the edit field. If there is already text inside the field use 

the arrow keys to move to the end of the text (Shift - right arrow 

will jump to the end of the text). The backspace key can be used 

to erase the text. 

• 	 Enter the text from the keyboard. 

• 	 When the label is complete click on the OK button. To back out of 

creating the label click on Cancel. 

• 	 The text tool works like the Rectangle tool at this point. You create 

a rectangle defining the area the text will print in. Place the cursor 

on one corner of the area and press the Selection button. 

• 	 Move the cursor to the opposite corner of the area and click the 
Selection button. The rectangle may be any size in height or length 

that you need. Draw will adjust the text to fit into this space. 

Dimension Lines 

To create a dimension line: 

• 	 Select Dimension from the Tools menu. 

• 	 Place the cursor at the beginning point of the line and click the Selection 

button. A ghost line will appear under the cursor. 

• 	 Move the cursor to the end point of the line and click the Selection 
button again. 

9-5 




J N S J D E A E G J S DRAW 

Part 

Parts are a very powerful feature of the Draw program. Parts can be 

thought of as drawings within drawings. You can collect various drawing 

elements (lines, polygons, text, arcs, dimensions, and even other parts) 

and create a new element with a name of your choosing. If you are 

designing the layout of several offkes, you could create parts for chairs, 

desks, and even water coolers. These parts can be stored on disk for 

LIse in future drawings . 

Once in a drawing, the part can be manipulated with the same tools 

you lise to modify a line, arc, text, or other graphic element. If the 

part contains dimension lines, those lines will reflect the real dimension 

of the part. If the part is resized , the dimension is recalculated. 

When YOll save your drawing, the parts used in that drawing arc saved 

in the drawing file. If YOll need to send a copy of the drawing (on 

disk) to another L1ser of Draw, you don 't have to worry aboLlt forgetting 

a part , Draw keeps those parts "In Stock" for yOllr use . You can create 

a library of parts by saving indiviclual parts to disk. 

Sometimes the part is larger than the window YOll are using. If YOll 

try to place a part into this window the message Part Is Too Large 

will be displayed. To solve this problem choose a smaller part, Zoom 

Out, or resize the part in a larger window and use the Edit menu 

to copy it into your active window. 

More information can be found on parts under the Group command 

in Chapter I I and in Chapter 13, The Parts Library. 

To place a part in the drawing: 

• 	 Select Part from the Tools menu. lfrhe drawing has no parts "In Stock", 

you will get the message Drawing has no parts. You cao create a 

part with the Group function in the Edit menu , or use the Open Part 

function in the Project menu. 

9-6 



TOO L S 


• If the drawing does have parts, a window will appear listing the "Parts 

\ 
In Stock" for that drawing. Click on the part you want to use. You 

\ 	 can also type the name of the part in the edit field, by clicking in 

the box titled "Part" and typing in the name of the part. When the 

part name is correct press RETURN or select the OK button. If the 

part you have chosen cannot be found in the drawing, you will get 

the message Can't Find The Part, select a new part by repeating the 

steps above. 

• 	 Once you have selected a part, click the Selection button on the drawing. 

A rectangle representing the part wi II appear attached to the cursor. 

Drag the rectangle to where the part should be placecl and press the 

Selection button to put the part down . 

.-..-' 
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10 Editing Objects 

The edit functions under the Tools menu are used to adjust individual 

objects or shapes. There are commands to move, rotate, copy, erase, 

and change the size or color of objects. You can move ohjects behind 

others, explode parts into their sub-pieces, and fine tune shapes from 

the keyboard. 

The editing tools all work in a similar manner: choose rhe rool, place 

the cursor on the shape, and click the Selection button to choose 

the object. Once chosen the shape may then be al terecl . Prcss the 

Menu button to back out of editing an object once it has been selected . 

When choosing a shape be sure to place the cursor on one of the 

lines making up the shape. Draw sees a rectangle for example. as a 

series of 4 lines. Placing the cursor inside the rectangle would have 

no effect. The cllfsor mllst be on one of the lines for Draw to recognize 

which object to choose. If Grid Snap is on , Draw will read the 

coordinate from the nearest grid intersection and may not recognize 

the object YOll are trying to select. 

Something else the editing tools have in common is the selection point 

used when the object is chosen for editing. This point is the focal 

10-1 



INS IDE A E GIS DRAW 

point for the action. Rotation as an example, occurs around the point 

where YOll place the cursor when you choose the object. When dragging 

an object the point is the "handle" for the drag. 

Drag It 

The Drag It function moves an object from one point to another. The 

point of the object YOLI click on to choose it for dragging becomes 

the handle. 

If you need to align the object to a specific set of coordinates turn 

on the crosshairs first. Then choose a piece of the object like a corner 

for the alignment by clicking on it to select the object. Once the object 

is selected move the crosshairs to the new position. 

To drag an object: 

• 	 Select Drag It from the Tools menu. 

• 	 Place the cursor on the object to move and click the Selection button. 

A ghost frame appears arollnd the object when it is selected. 

• 	 Move the cursor to the new position. The ghost frame will follow 

the cursor. 

• 	 When the ghost frame is correctly positioned in the new location click 

the Selection button. The object will be erased from the old position 

and redrawn in the new. 

Rotater 

Rotater lets you grab an object and move it in a clockwise or counter 

clockwise manner. The axis of rotation is at the point YOll click on 

when you select the object for rotating. 
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To rotate an object: 

• 	 Select Rotater from the Tools menu. 

• 	 Place the cursor on the object to rotate and click the Selection button. 

A ghost frame appears around the object when it is selected. 

• 	 Move the mouse in a circular motion until the frame is aligned where 

you want the object repositioned. You have better control of the rotation 

the ti.lrther from the axis your cursor is located. For example, if you 

rotate the object with the cursor in the same position as the axis 

the frame will jump as much as 90 degrees with a small movement 

of the mouse. Moving the cursor away from the axis first however, 

wiJl give you a degree by degree control of the rotation. 

• 	 When the frame is where you want it click the Selection button again. 

Clone 

Clone makes an exact copy of the selected object and allows you to 

move the copy in a manner similar to the Drag It ti.ll1ction. 

To make a copy o£ an object: 

• Select Clone from the Tools menu. 

• Place the cursor on the object to copy and click the Selection button. 

A ghost frame appears around the object when it is selected. 

• Move the cursor 

the cursor. 

to the new position. The ghost frame will follow 

• When the ghost frame is correctly positioned in the new location click 

the Selection button. The object will be copied into the new position. 
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Eraser 

To erase an object from a drawing: 

• 	 Select Eraser from the Tools menu. 

• 	 Choose the object to erase. A frame will appear around it to indicate 

it is selected. 

• 	 Press the Selection button again to erase the object. To cancel the 

command press the Menu button. 

Remember, if you make a mistake you can always UNDO your last 

action , just don 't do something else before you forget to UNDO that 

mistake. 

Explode 

Explode breaks a part back into its component objects. This allows 

editing of a part. 

To break a part back into its sub-components: 

• 	 Select Explode from the Tools menu. 

• 	 Choose the part to explode. A frame will appear around it to indicate 

it is selected. 

• 	 Press the Selection button again to accept the choice. The individual 
elements of the part are now as they were before the Group command 

was issued. To cancel the command press the Menu button. 

Sizer 

The Sizer function adjusts the current size of a shape. When the shape 

is selected there are two frames that appear. The first identifies the 
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shape in the normal manner and the other is an adjustable frame for 

displaying the new size of the object. Sizing is <.lone in a proportional 

manner. 

To change the size of an object: 

• 	 Select Sizer from the Tools menu. 

• 	 Choose th<: object you wish to change. Two frames will appear aroun<.l 

the object. 

• 	 Move the cursor to adjust the secon<.l frame. When the frame omlines 
the size you want the shape to be press the Selection button. The 

shape will be erased and then redrawn in the new size. To abort Sizer 

press the Menu button at any point. 

Back 

As you create a drawing Aegis Draw stores the order the shapes are 

made in. When the drawing is refreshed the shapes are redrawn in 

this same order. This is important when you want certain shapes to 

appear on top of others. The Back function allows you to change 

this order by moving an object behind another. When an object is 

edited with Back it is moved to the head of the drawing list so it 

is the first object drawn. 

To move an object behind another: 

• 	 Select Back from the Tools menu. 

• 	 Choose the object to change. A frame will appear around it to indicate 
it is selected. 

• 	 Press the Selection button again to confirm your selection. To abort 
the operation press the Menu button. 
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Color 

The Color function can be lIsed not only to change the color, weight, 

and pattern of an object but whether it is outlined or filled, smoothed 

or normal as well. Color looks to the Filled, Outline, and Smoothed 

preference when changing the color of an object. 

To change the color of an existing object: 

• 	 Select Color from the Tools menu. 

• 	 Choose the new color from the Color menu. 

• 	 Select the ohject to change. A frame will appear around it to indicate 

it is selected. 

• 	 Press the Selection hutton again to confirm your choice. To abort the 

action at any time press the Menu button. 

Stats 

Stats allows you to set the parameters of an object by entering numbers 

directly. Each type of element has its own stat window. A circle would 

have a window showing radius and center coordinates, text would 

show you the text, location, and width / height of the individual 

characters. If you select a line, polygon, or rectangle you will get 

information on the coordinate of the closest point. 

Each requestor has a Modify and Cancel button, and one or more 

edit boxes containing parameters about the selected object. To adjust 

an object directly enter the changes in the edit boxes and then click 

on the Modify button to accept the changes. To exit the requestor 

without any changes being accepted use the Cancel button. 
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To use the stats function: 

• 	 Select Stats from the Tools menu. 

• 	 Choose the'object to change. A frame will appear around it to indicate 
it is selected. 

• 	 Press the Selection button again to accept the choice. A requestor 
will appear with the Stats information. To cancel the command press 

the Menu button. 

• 	 Use the keyboard to change the information in the edit boxes. Once 
all the parameters are the way you want them select the Modify button. 

To exit the requestor with all changes ignored use the Cancel button. 
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CHAPTER 


1 Editing Areas 

The commands under the Edit menu are similar to the editing functions 

in the Tools menu. Instead of changing individual objects though, they 

affect all of the objects in an area. Another difference is the Edit 

commands only work once per menu selection. Unlike the Tools editing 

commands which stay turned on until you choose another tool , 

everything under the Edit menu works only once. So if you choose 

to Size an area and abort (or complete) the operation you will need 

to choose it again to continue using the Size function. 

Most of the commands work using an area known as the "clipboard". 

This is a separate area where objects may be "cut" or " copied " to 

and "pasted" from. For example, to make a duplicate of a circle and 

several lines requires only selecting Copy and then framing the area 

to duplicate. The contents of the frame are then copied into the 

clipboard. Once there, they may be pasted back into the draWing at 

any point with the Paste command. 

The Cut,Copy, and Paste features may also be used to move areas 

to other drawings. By loading two drawings at once in different 

windows, objects may be moved from one to the other via the clipboard . 
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Undo 

The Undo function works with both the Tools and Edit menus. Its 

basic function is to remove the last action from the drawing. Such 

actions as creating, erasing, rotating, or dragging a shape are all "undo
able" . So are the Cut and Paste features. You cannot undo an Explode, 

Part, or Group action. The Undo menu selection will appear shaded 
and be unselectable when it cannot be used. 

To remove the last action from the drawing: 

• 	 Select Undo from the Edit menu . 

Cut 

Cut erases an area from the drawing and copies it into the clipboard. 
Use this function with Paste to move a series of objects to another 
point on the drawing. 

To cut an area out ofa drawing: 

• 	 Select Cut from the Edit menu. 

• 	 Place the cursor at one corner of the area you want to cut and press 
the Selection button. 

• 	 Move the cursor to the opposite corner. A frame will appear around 
the area. Be sure the objects you want to move are entirely enclosed 
by the frame. 

• 	 When the frame encloses all the shapes to cut, press the Selection 
button again. The objects inside the frame will be cut from the drawing 
into the clipboard. 
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Figure 11.1 Using a Selection Frame. All of [he edit commands use a seleaion frame [0 define [he area they are 
[0 change. For example. [0 use [he Copy command first selea i[ from [he Edit menu. Place [he cursor above 
and [0 [he right of [he oqjeas you w ant [0 copy and press [he Seleaion burron. Move [he cursor [0 [he oppos/[e 
corner. As you move [he cursor a frame appears This is [he seleaion frame. All of [he oqjects comple[ely inside 
[he frame when I[ is comple[e will be copied [0 the clipboard by [hiS amon. When [he frame is correa press 
[he seleaion burron again. The important point about [he frames is [hat an obJea must be enclosed entirely by 
[he frames for [he aaion [0 be performed on it Objects [hat extend outside [he frame are ignored. 
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Copy 

Copy works similar to Cut except the objects are not erased from 

the drawing. 

To copy an area into the clipboard! 

• 	 Select Copy from the Edit menu. 

• 	 Place the cursor at one corner of the area you want to copy and press 
the Selection button. 

• 	 Move the cursor to the opposite corner. A frame will appear around 
the area. Be sure the objects you want to copy are entirely enclosed 

by the frame. 

• 	 When the frame encloses all the shapes to copy, press the Selection 
button. The objects inside the frame will be copied into the clipboard. 

Paste 

The Paste function works with Cut and Copy. It pastes anything in 

the clipboard into a drawing at a specified point. 

To paste the contents of the clipboard into a drawing: 

• 	 Select Paste from the Edit menu . 

• 1 A frame will appear attached to the cursor. This is the contents of 

the clipboard. Position the frame where you want the area to be and 

press the Selection button. 

Erase 

The Erase function removes all the objects inside a selected area from 

the drawing. 
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To remove all the objects inside an area: 

• 	 Select Erase from the Edit menu. 

• 	 Place the cursor at one corner of the area you want to erase and 
press the selection button. 

• 	 Move the cursor to the oppostie corner. A frame will appear around 
the area. Be sure the objects YOll want to erase are entirely enclosed 

by the frame. 

• 	 When the frame encloses all the shapes to erase press the Selection 
button. 

Modify 

The Modify command has a sub-menu containing a variety of functions 

for changing an area. The commands work similar to the other functions 

under Edit in that you choose an area first using a frame and then 

adjust its contents. The functions allow you to change an area's size, 

rotate it , distort its shape, or adjust the color, pattern, or weight of 

the lines. 

Size 

The Size command is similar to the Sizer under the Tools menu. The 

exception being you choose an area rather than a single object to 

change. To back out of the operation at any time press the Menu button. 

To adjust the size of all the objects in an area: 

• 	 Select Modify from the Edit menu. A sub-menu box will open to the 
right. 

• 	 Move the cursor until Size is highlighted and release the Menu button. 
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• 	 Place the cursor on one corner of the area you want to change and 
press the Selection button. 

• 	 Move the cursor to the opposite corner. A frame will appear around 
the area. Be sure all the objects you want to change are inside the 

frame. 

• 	 When the frame is correct press the Selection button again. The frame 
will change to a sizer tool. There are two frames one inside the other. 

The outside frame shows the areas current size. The inside frame is 

the new size when the operation is complete. 

• 	 Move the cursor unti! the adjustable frame is correct for the new size 

of the area and press thc Selection button. The contents will be erased 

and redrawn in the new size. 

Rotate 

Rotate will move all the objects in an area around the area's center. 

Like its cousin Rotater this function has better control of the rotation 

the further away the mouse is from the frame during the operation. 

To cancel the function at any time press the Menu button. 

To rotate the objects in an area: 

• 	 Select Modify from the Edit menu. A sub-menu box will open to the 

right. 

• 	 Move the cursor until Rotate is highlighted and release the Menu button. 

Place the cursor on one corner of the area you want to rotate and 

press the Selection button. 

• 	 Move the cursor to the opposite corner. A frame will appear around 
the area. Be sure all the objects you want to rotate are inside the 

frame. 
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• 	 Once the frame is correct press the Selection button again. The frame 
will now move with the mouse. Adjust the frame until the angJ<: of 

rotation is correct. 

• 	 When the area is where you want it press the Selection button to 
end the operation. The objects will be erased and redrawn in their 

new position. 

Distort 

Distort is like the Size command except where Size adjusts the area 

proportionally (largerIsmaller), Distort allows YOll to change height 

and width independently. For example, the objects in an area can be 

stretched very long without changing the height. This also allows for 

"tlipping" an area to create a mirror image. Flipping is done by dragging 

one side of the selection frame to the opposite side. 

As with the other Edit commands, you first create a frame around 

the area to change. The bottom left of the frame is the controlling 

side. To mirror an object upward on a drawing you would begin the 

frame on the top and move down. When the frame is complete the 

bottom frame line will be moved upward. To abort the operation with 

no changes made use the Menu button. 

To change the height/width ratio of all the objects in an area: 

• 	 Select Modify from the Edit menu . A sub-menu box will open to the 

right. 

• 	 Move the cursor until Distort is highlighted and release the Menu button. 

• 	 Place the cursor on one corner of the area you want to change and 
press the Selection button. 
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Paint 

• 	 Move the cursor to the opposite corner. A frame will appear around 
the area. Be sure aU the objects you want to change are inside the 

frame. 

• 	 When the frame is correct press the Selection hutton again. The frame 
wiII now move in response to the mouse. 

• 	 Adjust the frame until it is the new shape you want and press the 

Selection button. The contents of the frame will be erased and redrawn 

to reflect the new frame. 

The Paint command is a limited version of the Color command from 

the Tools menu. It changes only the color of the objects inside the 

selection frame. Paint does not change any other feature of an ohject 

(like tlllecl/not filled, line weight , etc.) . 

To change the color of all the objects in an area: 

• 	 Choose the color you want to change all of the ohjects to from the 
Color menu. 

• 	 Select Modify from the Edit menu. A sub-menu box will open to the 

right. 

• 	 Move the cursor until Paint is highlighted and release the Menu button. 

• 	 Place the cursor on one corner of the area you want to change and 
press the Selection button. 

• 	 Move the cursor to the opposite corner. A frame will appear around 
the area. Be sure all the objects you want to change are inside the 

frame. 

• 	 When the frame is correct press the Selection button again. All of 

the objects in the frame will be erased and redrawn in the new color. 
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Pattern 

Pattern is similar to paint except it is concerned with the line and 

fill pattern of the objects inside the selection area. If the Filled 

preference is on all of the objects in the area will be filled with the 

current tllJ pattern. If the preference is Off the unfilled objects will 

be changed to the current line pattern. The color of the objects is 

not changed. 

To change the line or fill pattern of all the objects in an area: 

• 	 Select Modify from the Edit menu. A sub-menu box will open to the 

right. 

• 	 Move the cursor until Pattern is highlighted and release the Menu 
button. 

• 	 Place the cursor on one corner of the area you want to change and 
press the Selection button. 

• 	 Move the cursor to the opposite corner. A frame will appear around 
the area. Be sure aU the objects YOll want to change are inside the 

frame. 

• 	 When the frame is correct press the Selection button again. The objects 

will be erased and redrawn in their changed form. 

Weight 

The Weight feature of Modify changes the line weight of all the objects 

in the selection frame. The currently selected weight from the Options 

menu is used. The colors, and patterns of the lines are not affected. 

To adjust the weight of all the objects in an area: 

• 	 Select Modify from the Edit menu. A sub-menu box will open to the 

right. 
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• 	 Move the cursor until Weight is highlighted and release the Menu 
button. 

• 	 Place the cursor on one corner of the area YOll want to change and 
press the Selection button. 

• 	 Move the cursor to the opposite corner. A frame will appear around 
the area. Be sure all the objects you want to change are inside the 
frame. 

• 	 When the frame is correct press the Selection button again. The objects 
will be erased and redrawn in their changed form . 

Group 

Group is used in conjunction with the Part tool. The Group command 

combines objects together to make a part out of them. Once the objects 
have been grouped they are treated by Draw as a single object. Any 

of the Tools commands may be used on them. 

A part is given a name when you group it. This name is added to 

a list of names in stock for a particular drawing. Names may not be 

duplicated within a drawing. 

More information on parts and grouping can be found under the Part 

heading in this section and in Chapter 13, The Parts Library. 

To group objects together to create a part: 

• 	 Select Group from the Edit menu. 

• 	 Place the cursor on one side of the area to make into a part and press 
the Selection button. 
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• 	 Move the cursor to the opposite corner of the area. A frame will appear 

around the area. Make sure all the objects are enclosed by the selection 

frame. 

• 	 When the frame is correct press the Selection button again. A requestor 

will appear with an edit box for the name of the part. To exit with 

no grouping performed select the Cancel button. 

• 	 Click in the edit box to select it. When the cursor appears in the 
edit box use the keyboard to type in the name of the part. 

• 	 When the name is correct press RETURN or click on the Name 
command. The objects are now grouped together. Any command from 

the Toois menu will work on the area as a unit. 
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CHAPTER 


2 Advanced Tools 

Layers 

Adding different layers to a drawing allows you to break it up into 

logical sections. A drawing of a house for example might be broken 

into structural, electrical, and plumhing layers. Each layer could then 

be shown or plotted by itself or together with any other selected layers. 

Each window on the desktop can show a different layer display. In 

the house example one window might show just the plumbing layer 

while another displays all three. 

There are 250 layers available for each drawing. The layers are numbered 

like the cells of a spreadsheet. There are 10 layers per letter for the 

letters A thru Y. So the first 10 layers are labeled AO thru A9 and 

the next 10 are BO thru B9 and so on. This is shown in the different 

layer requestors as a grid with the letters running along the top as 

column names and the numbers running vertically as row names. 

As objects are made they are assigned the currently active layer number. 

The default layer is AO. To change the active layer you use the Layer 

command and select the desired layer from the grid. 
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To control the layers being displayed use the Layers Shown command 

and mark all the desired layers in the grid. 

Layer 

To change the current active layer: 

• 	 Select Layer from the Preferences menu. A requestor will appear with 
the layer grid. You can only select a layer that is displayed in the 

current window. 

• 	 Choose the layer you want by clicking in the cell made by the 
intersection of its letter and number. For example, the first cell is 
AO in the extreme upper left corner. 

• 	 When the layer you want is active choose the OK button to exit the 
requestor. To leave without saving any changes lise the Cancel button. 

Layers Shown 

To change the displayed layers in the CU.t1.'ent window: 

• 	 Select Layers Shown from the Display menu. A requestor will appear 
with the layer grid. 

• 	 The cells of the grid act as on/ off switches. If a grid cell is dark that 
layer is active, to turn it off click on it. The cell will change to unshaded. 

To turn a layer on click on it. 

• 	 When the layer grid reflects the layers you want active choose the 
OK button to exit the requestor. To exit without saving any changes 

use the Cancel button. 

Data Snap 

The Data Snap function is a smart feature of Draw. When turned 
on it tries to guess what you want in the way of connecting lines. 
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Figure 12.1 Using the Layer Requestor. Aegis Draw allows you to split a drawing into different layers k objects 
are created they are assigned to the culTently aaive layer. Specific layers may be seleaed for display or printing. 
The default serring is for all layers displayed. There are 250 layers available. They are named like the cells of a 
spreadsheet with the first being AO and the next AI. The "A'" series continues through A9 and then "B" startS with 
BO, All of the layers are displayed on the layer requestor with the lerrers across the top and the numbers down 
the side. The Intersealng cell of a lerrer and a number is the switch for that layer. With the Layer command you 
may selea the CUlTently aaive layer. When the requestor appears place the cursor on the layer you want aaive 
and press the Seleaion button. The square will darken to indicate seleaion. To choose which layers will be displayed 
use the Layers Shown command under the Display menu When the requestor IS displayed click in the cells of 
the layers you want shown The switCh works both ways, To tum a layer off just click on it. 
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For example, if you create a line with it turned on Draw will look 

at either end of the line to see if there is another line in the area. 

If there is, Draw will assume you want the the two lines to actually 

touch and will connect or "snap" the lines together. 

If the distance between the two lines is greater than 4 pixels horizontally 

and 2 pixels vertically, Draw will assume you don't want the lines 

to connect. 

If Grid Snap is turned on Data Snap will be ignored. 

To turn Data Snap on or off: 

• 	 Select Data Snap from the Preferences menu. A sub-menu box will 

open to the right with the two on/ off options. 

• 	 Move the cursor until the option you want is highlighted and release 

the button. 

Rounding 

The Rounding function lets you specify the precision of the drawing. 

For example you might want a building to be accurate to 1/ 100 of 

your units in the drawing. If a value of .01 was used for rounding 

all of the coordinates would be rounded to this value. A coordinate 

of 22 .245 would round to 22.25. You can use this as a way of setting 

the number ofdigits ofprecision, or to prevent odd values from showing 

up in dimensions. 

To adjust the rounding of fractions: 

• 	 Select Rounding from the Preferences menu. 

A requestor will prompt you for the current rounding value. Enter 
the value and press RETURN or select the OK button. To exit without 

changing the current rounding select the Cancel button. 
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Figure 12.2 Using the Fonnat Requestor. The Format command allows definition of a drawing's height. width and 
origin in respea to both paper and the computer. The Height and Width of the drawing refer to the numbers 
shown on the rulers These are the maximum values the draw ing can scroll to. The Origin of the drawing is the 
starting point. Its va lues refer to the minimum values of the drawing. They are located in the bottom left of a 
full display drawing. The origin of a drawing may be any positive or negative value and can be changed at any 
time. The Height and Width of the paper re fer to the plotter or printer. For plotters. the val ues define the aaual 
paper size the plotter has to work w ith. For printers. it controls the size of the printout vertically and honzontally 
Aspect is for plotters only and controls which way the plot will be placed on the paper. To control the aspea 
for a printer use the Preferences program. 
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Smoothing 

Smoothing is one of the more powerful functions available in Aegis 

Draw. Also known as curve fitting , it allows you to create curves with 

the straight line tools. When Smoothing is turned on the points of 

a shape are fitted into the best possible curve. For example, a connected 

series of up and down lines in a row would appear as a sine wave 

with Smoothing. 

To turn the Smoothing function on or off: 

• 	 Select Smoothing from the Preferences menu. A sub-menu box will 

open to the right with the On/ Off options. 

• 	 Move the cursor until the option you want is highlighted and release 

the Menu button. 

Format 

The Format option gives you control of a drawing's width, height, 

and paper size. It also sets the origin of a drawing. This is the x and 

y number combination in the lower left corner of a full display. They 

are the smallest numbers to appear on the rulers. The origin can be 

set to any positive or negative value. The rulers will adjust themselves 

according to the origin and the units you have specified with the Units 

command. You may change the origin of a drawing at any time. 

The paper size (width and height) tells Draw the size of your plotter. 

It may also be used to adjust the print area on a printer. The Format 

requestor also has two edit boxes for paper origin. This tells Draw 

where in a drawing you want the plot to start. The lower left corner 

of the paper will be set to the x ,y ruler location indicated here. This 

allows you to plot sections of a drawing. To print sections of a drawing 
with a printer, adjust the view in the active window until it displays 

the print you want. The Print command sends the current view to 

the printer. 
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Below the Paper Origin edit boxes are two buttons controlling the 

paper aspect. This command is for plotters only. It adjusts whether 

the plot will appear on the paper horizontally or vertically. To adjust 

the vertical , horizontal aspect for a printer use the Preferences section 

of the Workbench. 

To adjust the output formats for a drawing: 

• 	 Select Format from the Options menu. The Format requestor will be 

presented. 

• 	 Enter the desired changes directly in the edit boxes (click on a box 
to select it, then enter new values from the keyboard). 

• 	 When the values are set properly select the OK button to exit the 
requestor. Use the Cancel button to exit without saving any changes. 
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CHAPTER 


13 The Parts Library 

One of the great features of Aegis Draw is its ability to create parts. 

A part is a collection of objects (lines, text, circles, dimension lines, 

etc.) grouped together to form an independent object. The part can 

then be used in the drawing instead of having to recreate it each time. 
A part may also be saved to disk for use in other drawings. 

You can build a library of commonly used symbols for lise in all of 

your drawings. Once a part has been loaded into a drawing it's in 

stock for that drawing. If you are sending a Draw file to another Draw 

user you don't have to worry about sending the part file since Draw 

will already have it included inside the drawing. 

Creating, saving, and using parts are all detailed in this chapter and 

also under the respective individual menu commands. 
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Using Parts 

Parts are best used for repetitIOus tasks like chips in circuit board 

design or doors and windows in architecture. They take up a little 

more memory than just the individual objects that comprise them so 

it's better memory management to use them only when they will be 

repeated. Each part made after the first one saves space. In the case '

ofa complicated part involving several complicated objects, the memory 

savings can be dramatic. 

Draw remembers the size of a part even if it has been saved to disk 

and is brought into another drawing. It is possible to attempt using 

a part that is too large for the area you are working in. Solutions to 

this problem are zooming out to a level where the part will fit and 

then resizing it, or opening another larger window (separate drawing), 

resizing the part there and using Cut and Paste to move into the 

current drawing. 

Creating a Part 

Parts are created with the Group command detailed in Chapter 11. 

Once created they may be called lip for use in a drawing with the 
use of the Part command under the Tools menu. 

To group objects together to create a part: 

• Select Group from the Edit menu. 

• Place the cursor on one side of the area to make into a part and press 
the Selection button. 

• Move the cursor to the opposite corner of the area. A frame will appear 
around the area. Make sure all the objects are enclosed by the selection 
frame. 
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Figure 13.1 Naming a Part. Parts allow you to group objeru together so they may be treated by Draw as a single 
item. This IS done With the Group command under the Edit menu. Once the obJeru have been chosen w ith 
a selealon frame they are given a name. Each part must have a unique name. Once named the part may be 
used by seleaing it with the Part command under the Tools menu. 

Figure 13.2 The Parts Requestor. Once a part has been created it may te used like any other objea creating tool 
under the Tools menu. The parts requestor is presented by seleaing the Part command. The center of the requestor 
has a scrolling list of all the parts in the drawing To use a part. click on Its name In the scroll ing list or enter 
it dlrealy in the edit box labeled, Part. If there are no parts In the drawing selecting [he Part command will have 
no effea. 
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When the frame is correct press the Selection button again. A requestor 

will 	appear with an edit box for the name of the part. To exit with 

no grouping performed select the Cancel button. 

• 	 Click in the edit box to select it. When the flashing cursor appears 

in the edit box use the keyboard to type in the name of the part. 

• 	 When the name is correct press RETURN or click on the Name 
command. The object<; are now grouped together. Any command from 

the Tools menu will work on the area as a unit. 

Calling Up a Part 

Once created, parts may be used repeatedly in a drawing by calling 

them up with the Parts requestor. After the part has been selected 

it can be put down as many times as you need. The Part command 

works like the Line command or any of the other tools: as long as 

it is selected, Draw is creating the chosen part . 

To place a part in the drawing: 

• 	 Select Part from the Tools menu. If the drawing has no parts "In Stock", 
you will get the message Drawing has no parts. You can create a 

part with the Group function in the Edit menu, or use the Open Part 

function in the Project menu. 

• 	 If the drawing does have parts, a window will appear listing the "Parts 

In Stock" for that drawing. Click on the part you want to use. You 

can also type the name of the part in the edit field, by clicking in 

the box titled Part and typing in the name of the part. When the 

part name is correct press RETURN or select the OK button. If the 

part you have chosen cannot be found in the drawing, you will get 

the message Can't Find The Part. Select a new part by repeating the 

steps above. 
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• 	 Once you have selected a part, click the selection button on the drawing. 
A rectangle representing the part will appear attached to the cursor. 

Drag the rectangle to where the part should be placed and press the 
Selection button to put the part down. 

Exploding a Part 

Explode breaks a part back into its component objects. This allows 
editing of a part. If the objects are changed in the part a new grouping 
must be performed to save the new part. The old part will still be 

in stock. 

To break a part back into its SUb-components: 

• Select Explode from the Tools menu. 

• Choose the part to explode. A frame will appear around it to indicate 
it is selected. 

• 	 Press the Selection button again to accept the choice. The individual 
elements of the part are now as they were before the Group command 

was issued. To cancel the command press the Menu button. 

Storing a Part on Disk 

To use a part in other drawings it must first be saved to disk. The 

part must already have been made with the Group command before 

selecting Save. 

Draw keeps a parts directory on disk , but it is not required that parts 

be stored in the directory. To save the part to another directory just 
change the name in the directory edit box of the storage requestor. 
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To save a part to disk: 

• 	 Select Save As from the Project menu. A sub-menu box will open 

to the right with the different file types .. 

• 	 Move the cursor until Part is highlighted and release the Menu button. 

The Parts In Stock requestor will be displayed. 

• 	 Choose the part to save from the list by clicking on it. The name 
will be entered into the Part edit box. If you change the name of 

the part , Draw will not find it in the list and wi II cancel the action. 

• 	 When you have the part you want select the OK button. To back out 

of the operation select Cancel. 

• 	 The storage requestor will be displayed next. Details on using this 

requestor may be found in Chapter 14. If you wish to save the part 

into a directory other than Parts, click in the Drawer edit box and 

change the name to the proper directory. Leaving this area blank will 

direct the file to the current directory. 

• 	 You may change the name of the part at this time. To do this click 
in the File edit box. When the name and directory are correct choose 

the OK button. To exit the requestor without saving the part use the 

Cancel button. 

Loading a Part from Disk 

Parts that have been saved to disk from other drawings may be loaded 

into a drawing with the use of the Open command. If a part is larger 

then the current Drawing, you may not be able to use it. 

Once the part is loaded into the drawing it 's added to the list of Parts 

In Stock. To use the part go to the Part command and select it from 

the requestor. 
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To load a part from disk: 

• 	 Select Open from the Project menu. A sub-menu box will open to 

the right displaying the different file types. 

• 	 Move the cursor until Part is highlighted and release the Menu button. 

The storage requestor will appear. Details on using this requestor may 

be found in Chapter 14. 

• 	 If the part you want is not in the Parts directory, click in the Drawer 

edit box to select it and change the name to the correct directory. 

Leaving the box blank will activate the current directory. Press RETURN 

to see a list of files in the new directOry. 

• 	 Choose the part YOll want by clicking on it. The name will be entered 
into the File edit box. Alternatively you may enter the name of the 

part into the edit box directly. 

• 	 When the directory and part name are correct select the OK button. 

To abort the loading use the Cancel button. 

• 	 After the file is loaded you will be returned to the drawing with the 
current active tool. Use the Part command to access the newly loaded 

part. 
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14 Storage 

The Storage Requestor 

All file handling is done through a window called the Storage Requestor. 

From here you can view the files on disk, switch directories, and open 

or close a file. 

There are two edit boxes for entering file and directory information. 

The edit box on top, labeled Drawer, is for changing directories. You 

can gain access to a directory or disk by entering the name here followed 

by a RETURN. The edit box on the bottom, labeled File, is the name 

of the file you wish to load or save. 

Directly below the drawer box is a list of files in the current directory. 

To the right is a slider gadget for scrolling through the files. By dragging 

the black marker up and down you can scroll the file list. 

A shortcut for loading a file or switching directories is available by 

clicking on a name in the file list. If the name is a directory it will 

be loaded into the Drawer edit box otherwise it will be loaded into 

the File edit box. 
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The OK and Cancel buttons are for completing the request (OK) 

or backing out without loading or saving (Cancel). 

Saving to Disk 

Drawing 

Drawings are kept in a directory named "Drawings". It is not required 

for drawings to be saved here. To save a drawing to a different directory 
just change the name in the Drawer edit box. 

To save the drawing in the current window to disk: 

• 	 Select Save As from the Project menu. A sub-menu box will open 
to the right with the different types of files you can save. 

• 	 Move the cursor until the option Drawing is highlighted and release 
the Menu button. 

• 	 Place the cursor in the File edit box and press the Selection button. 
This is where you enter the name to give the drawing. There are two 

ways to enter data here: by choosing one of the names from the scrolling 

file list or by typing the data in. To type the data in use the arrow 

keys to move the cursor beyond any data already displayed and then 
backspace to remove what you don't want. Now type in the new name. 

To enter a name from the list just click on it. Saving to the exact 

same name will destroy any data in that file and replace it with the 

drawing you are saving. 

When the name is complete press the OK button. 

Part 

Draw keeps a parts directory on disk. It is not required that parts 
be stored in the directory. To save the part to another directory just 
change the name in the directory edit box of the storage requestor. 
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Figure 14.1 The Storage Requestor. To load drawings into Draw or save them to disk requires use of the storage 
requestor. Draw can save drawings, parts, and bitmaps (w indow dumps in IFF). Drawings and parts can be loaded 
Into the program. On the Draw disk are direaories already set up for your use. Draw ings are kept in one and 
parts in another. This IS not a requirement of the program. only a convenience Since Aegis Draw does not require 
file extensions to determine a File type it is easier to separate them WIth direaones. The requestor is a multi-tasking 
tool. As you use It the disk is being read and the flies sorted and displayed in the scrolling lise This is why the 
list may seem to change constantly. You may choose a different direaory by entering Its name in the edit box 
at tile tOp. Press RETURN when the name IS correa and the flies in that direaory will be displayed in the list. 
To selea a file. click on it in the scrolling list or enter the name direaly in the edit box at the bonom. Pressing 
RETURN afterward will have me same effea as choosing me OK bunon 
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To save a part to disk: 

• 	 Select Save As from the Project menu. A sub-menu box will open 

to the right with the different tile types. 

• 	 Move the cursor until Part is highlighted and release the Menu button. 

The Parts In Stock requestor will be displayed. 

• 	 Choose the pan to save from the list by clicking on it. The name 
will be entered into the Part edit box. If you change the name of 

the part Draw will not find it in the list and will cancel the action. 

• 	 When you have the part you want select the OK button. To back out 

of the operation select Cancel. 

• 	 The storage requestor will be displayed next. If you wish to save the 

part into a directory other than Parts click in the Drawer edit box 

and change the name to the proper directory. Leaving this area blank 

will direct the tile to the current directory. 

• 	 You may change the name of the part at this time. To do this click 

in the File edit box and enter the new name. When the name and 

directory are correct choose the OK button. To exit the requestor 

without saving the part use the Cancel button. 

Bitmap 

Bitmaps are pixel representations of drawings that may be loaded into 

other programs like Aegis Images™. Any program that uses the 640 

X 200 resolution mode of the Amiga and supports the IFF (Interchange 

Fi Ie Format) file type may use these files. 

Draw saves a picture or whatever the current active window is 

displaying. This includes any level of zoom. The rulers are not included. 

Grids are optional by turning them on or off with the Grid On/Off 

command under the Display menu. 
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To save a picture of the current window to disk: 

• 	 Select Save As from the Project menu. A sub-menu box will open 

to the right with the clifferent file types. 

• 	 Move the cursor until Bitmap is highlighted and release the Menu 

button. 

• 	 The storage requestor will be displayed next. If you wish to save the 

part into a directory other than the active one click in the Drawer 

edit box and enter the name of the proper directory. Leaving this 

area blank will direct the file to the current directory. 

• 	 Click in the File edit box and enter the name of the picture. When 

the name and directory are correct choose the OK button. To exit 

the requestor without saving the picture use the Cancel button. 

Loading from Disk 

Drawing 

When the Open command is performed for a drawing Draw will load 

it into the active window. If there is already a drawing in the window 

you will be prompted to kill it. Choosing OK will erase the window 

anel complete the loading of the new drawing. Selecting Cancel will 

abort the load operation. 

To load a drawing into a new window choose the New Drawing 

command under the Project menu. The new window will become 

the active window and any drawings will be loaded into it. 

To load a drawing from the disk: 

• Select Open from the Project menu. A sub-menu box will open 

the right showing the different options. 

to 
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• 	 Move the cursor until Drawing is highlighted and release the Menu 

button . The Storage Requestor will be presented. 

• 	 If the drawing is in a directory other than Drawings click on the Drawer 

edit box. Type in the name of the directory and press RETURN. The 

scroll list will change to the new directory. 

• 	 Enter the name of the file in the File edit box. You may either enter 

it manually or by clicking on the name in the scrolling file list. 

• 	 When the name is correct click on the OK button. To abort the operation 

use the Cancel button. 

Part files are like drawing files. A part is really just a miniature drawing. 

They are normally stored in the Parts directory. More detailed information 

can be found on parts in Chapter 13. 

To load a part from disk: 

• 	 Select Open from the Project menu. A sub-menu box will open to 

the right displaying the different file types. 

• 	 Move the cursor until Part is highlighted and release the Menu button. 

The storage requestor will appear. 

• 	 If the part you want is not in the Parts directory, click in the Drawer 

edit box to select it and change the name to the correct directory. 

Leaving the box blank will activate the current directory. Press RETURN 

to see a list of files in the new directory. 

• 	 Choose the part you want by clicking on it. The name will be entered 
into the File edit box. Alternatively you may enter the name of the 

part into the edit box directly. 
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• When the directory and part name are correct select the OK button. 

To abort the loading use the Cancel button. 

• After the file is loaded YOll will be returned to the drawing with the 

current active tool. Use the Part command to access the newly loaded 

part. 
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1 Output Devices 

A drawing may look nice on the screen of your computer, but it won't 

do you much good at the construction site. Printers and plotters enable 

Draw to transfer the output of the drawing to paper. Printers reproduce 

the screen. Plotters have a far higher resolution than most computer 

displays (typically 1000 units per inch). This means printers will 

produce stepped lines and other limitations of the screen. A plotter 

though, will transform a drawing into a clean, easily read plan or diagram. 

The plotter draws by moving a pen on the paper. There are no dots 

(pixels to printheads) or staircases, just smooth lines. If YOll are going 

to use Draw in your work, we suggest, cajole, and beg you to get 

a plotter for the job. 

There are two commands affecting the output of the drawing; Format 

anel Scale. Format allows you to control the plotter's paper size, origin, 

and the horizontal/vertical aspect. It is discussed in detail in Chapter 

12. Scale maps the number of units per inch of output. This is also 

only for plotters. 
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Scale 

Scale allows you to define a ratio of Draw units to plotter units. For 

example, if you were using a B size plotter (11" by 17" paper) and 

your drawing was 160 units across by 100 units in height (see Format), 

you might want each inch on the plotter to equal 10 units in the 

drawing (a scale of 10). A map of an area 100 miles by 100 miles 

could use a scale of 10 miles to the inch (on the plotter). Aegis Draw 

doesn't know the units in your drawing are miles, but it does know 

you want 10 of those units to be mapped to an inch on the plotter. 

The scale may be adjusted at any time before a drawing is plotted. 

To set the scale ofthe drawing: 

• 	 Select Set Scale from the Options menu. 

• 	 A requestor will appear showing the current scale. Click in the scale 

edit box and type in the desired scale. Press RETURN or select the 

OK button to accept the change. Use the Cancel button to exit without 
any changes. 

Plotting a Drawing 

Plotting large drawings can take hours. The Amiga provides a nice 

solution to that problem. Since it's a multi-tasking computer Draw 

can put the commands to the plotter in a plot file on disk and direct 

them to the plotter from there. It takes much less time to write the 

commands to disk than to execute them on the plotter so Draw can 

be ready again for use while the plotter is still working. The only 

catch here is a large drawing would create a large plot file and there 

may not be enough disk space. If this is the case Draw will inform 
you and ask if you want to plot directly. 

'-... 
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There are two options to plotting; Scaled and Un-Scaled. A Scaled 

plot will use the current scale in directing the plotter. An Un-Scaled. 

plot will reproduce the view in the active window in its actual size. 

Draw plots the current view of the active window. Zooming in will 

produce a plot of the new view. Scaled plots of sections of a drawing 

can be made this way. The current view also includes functions like 

layers and the grid. The active layers and the grid (if it is turned on) 

will be plotted. 

To plot the current view of the active window: 

• 	 Turn on the Plotter. 

• 	 Select Plot from the Project menu. A sub-menu will open to the right 
with the Scaled/ Un-Scaled options. 

• 	 Move the cursor until the option you want is highlighted and release 

the Menu button. 

• 	 The disk drive light will come on. It may take a moment for the file 
to be written to disk so don't panic if the plotter doesn 't start right 

away. When the file is finished Draw will be ready for use again. You 

can even work on the drawing being plotted. 

Plotters Supported 

Draw comes configured for the HPGL™ plotter language. The default 

Format (size of paper, etc.) is set up for the Roland DG DXY-980 

plotter. HPGL is the Hewlett Packard Graphics Language, a widely used 

plotter interface. If you are using the Roland plotter you should switch 

the plotter to use this interface. Draw does provide a method for 

supporting virtually any plotter in existence. There is a file titled 

"Plotter.driver" on your disk containing the information on how to 

talk to your plotter. You can modify this to support plotters that do 
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not use HPGL. This file also contains information on the plotter's size 

and resolution. See Appendix C, Aegis Draw File Types, for more 

information on modifying the plotter driver. 

Your plotter may use a parallel or serial interface. Use the Preferences 

program, Printer subsection, to set the interface requirements. 

Plotter Cabling 

Consult your plotter manual to determine what cabling you will need. 

If you are using the Roland plotter we suggest running it from the 

parallel printer port of the Amiga. The switch settings for the Roland 

plotter are: 

SW-1: 1-7 off, 8-10 on. 

SW-2: 1-6 off, 7-10 on. 

If your plotter uses the RS-232 serial port, you will have to get a cable 

that fits the Amiga properly. We have used a normal ribbon cable with 

success, but you may need assistance from the plotter documentation. 

Remember to use the Preferences program to set the printer to the 
proper port and baud rate. 

Printing a Drawing 

The results from a printer will not be as clean as a plotter because 

draw "dumps" the window to the printer. Since Draw doesn't know 

the size of the printout, Scale does not affect the printing. What you 

see is what you'll get. However, if you take the time to measure the 

paper, and use Zoom to set the view size of the drawing, you can 

create scaled prints of Draw. 

One technique to get more resolution from the printer is to divide 

the drawing into sections and print them individually. The different 
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pieces can then be taped together. The easy way to do this is to Zoom 

In to get the desired resolution, and use the scroll controls to move 
the display to all the sections of the drawing. Hitting the scroll button 
3 times wiII move you over one window's worth. 

To print the view of the current window to the printer: 

• Select Print from the Project menu. 

Printers Supported 

Draw will support any graphics printer present in the Amiga Preferences 
program. Consult your Amiga manual on how to use the Preferences 

program. 
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16 Problems 

Running Out of Memory 

A 512KAmiga has quite a bit of memory compared to the 64K computers 
of a few years ago. Running out of memory would seem to be an 
unlikely event. However, there are some features of the Amiga that 

consume large amounts of memory, and can cause Aegis Draw to run 

out of usable RAM. 

The high resolution graphiCS of the Amiga play a role in memory 

problems. Each window in Draw can consume more than 64K of 

memory. When a window is covered by another window or requestor 

the Amiga operating system "preserves" the covered portion of that 
window. If there was less than 64K of memory left and a window 
was covered, you would see a memory problem. Draw prevents you 
from opening more windows than it considers "safe". If you use more 

memory (quite a bit more) after you have opened the window, you 

could still run into problems. If you use the eLI instead of Workbench, 

you will have more memory to work with. 

Draw is also a large program. The program is about 140K in size, 

and uses additional memory when it first runs, but the drawings do 
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not use up much memory. Use of the parts feature can help the memory 

consumption problem if an item is going to be used more than onc<.:. 

The worst memory hog in a drawing is the FreeHand tool. Typical 

FreeHand items can use a few thousand bytes of memory each. It may 

be prudent to use a Line or Polygon tool and the Smoothing function 

to create the curves you need. 

The Amiga is a multitasking computer. If another program uses up 

memory Draw will be affected. If you are going to run another program 

at the same time as Draw, it may be wise to limit yourseU' to one 

window unless you have added expansion RAM beyond 512K (a very 

good idea). 

When you are low on memory Draw will inform you by posting a 

message on the screen. Draw will also close any windows created 

with the Zoom Window menu. This frees up memory without throwing 

away any drawings. If you are low on memory and have more than 

one drawing on the screen, closing one of the windows will free up 

quite a bit of that memory. 

You can monitor your memory consumption by using the About 

function in the Project menu. There should be more than 64K of CHIP 

memory available. There will be no FAST memory left unless you have 

added expansion RAM beyond 512K. Draw still needs the CHIP memory 

even if you have a large amount of FAST memory in your Amiga. The 

CHIP memory is used by the Amiga to store the covered portions 

of windows. If you do have FAST memory added to your Amiga, you 

will have more CHIP memory for windows. The Draw program and 

the drawings will load into FAST memory. This allows you to create 

more detailed drawings since they can use the FAST memory. More 

CHIP memory is left over for windows. Draw will let you open more 

windows if it sees more CHIP memory available. 

There are other indications you are running out of memory. If you 

execute a function that modifies a drawing (Edit menu, Paste, Modify 

items), and get a message there isn't enough free memory to allow 
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you to UNDO from this operation , you are low on memory. If you 

attempt to Save as or Open, and are informed there isn't enough 

memory to open the requestor, you are low on memory. Draw attempts 

to monitor the situation as best it can , but you should be aware of 

the memory problems that can occur. 

Out of Memory, Saving Your Work 

If you decide to save a drawing after you have been informed of the 

memory problems, you should be able to use the Save As menu item. 

Just follow the procedure as outlined in Chapter 14. If you are really 

low on memory and cannot use the Save As menu item then the 

Save function is the only solution. Make a habit of saving your work 

often. This can prevent real problems from occuring. It will also give 

the drawing a proper title , so Save will save it to the proper file name 

(as opposed to Untitled). 

If you have created parts, they will be saved along with the rest of 

the drawing. If you run out of space on the disk, Draw will inform 

you a problem has occured. You can use another drive or even swap 

the disk out of the internal drive (WAIT FOR THE DRIVE LIGHT TO 

GO OUT'). A good rule of thumb is to save the data often as you 

would not want to redo your work. If you don 't want to redo more 

than 1 hour of work, save every hour. On a multitasking computer 

you can never have too much memory. 

Using the Reference Section 

If you have a problem with a menu item or function, use the index 

to refer to the chapter that talks about that function. Many problems 

are a result of not understanding the use of a tool. The manual can 

be a great way of preventing problems. 

Also the Table of Contents is a good, fast method of looking up a 

command. In the back of the book is an appendiX, Aegis [)raw Menus. 
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This is a menu by menu listing of all the commands with a page reference 

for each. 

Don't Panic! 

If you get an area of difficulty with Draw, don't panic. If you think 

you have seen a bug, check the manual first to see if you are using 

the tool correctly. If it isn't described in the documentation, write 

down the circumstances and get in touch with us. We'll attempt to 

fix every problem that comes lip , but we won't be able to unless you 

giw liS the clues we need. Draw has been tested for months, but there's 

always the chance we overlooked something somewhere. 

If there is a feature you MUST HAVE, let us know. It may be something 

that can help other users. Write us with your suggestions, comments, 

and experiences with Draw. We may use this in the design of future 

products. We may be able to find a "workaround" to the problem. 

Anyway we will try to be as helpful as possible. 

',---,' 

'...../ 
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CHAPTER 


7 Using Genlock 

One of the great advantages of the Amiga is its ability to interface 

with video equipment. A notable tool developed by Commodore for 

use in this area is the Amiga 1300 Genlock System. This system aHows 

users to simultaneously produce video and stereo signals while running 

programs on their computer. The signals can come from a VCR, lazer 

disk , video tape, or other computer. Not only can the signals and 

program be produced on the machine together but the combination 

can be recorded on another device. 

The video signal produced by the Genlock is displayed in the background 

color (color zero). All other colors display over the top of it. The 

video out portion of the Genlock can switch from the Amiga signal 

to the video signal or produce both at the same time. 

There are a number ofcreative possibilities opened with the combination 

of Aegis Draw and Genlock on an Amiga. One of the most interesting 

is the ability to shoot an already existing drawing with a video camera 

and pipe the signal into the Amiga with Genlock. By changing the 

windows background color in Draw to zero (upper· left color in the 

Color menu) the drawing will appear in the window. It can then be 

traced with the Draw tools by drawing on top of the image. 
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Presentations to prospective clients can be created by capturing images 

of a real world project and combining them with computer generated 

diagrams. With the same device background music can be added to 

produce professional effects at a fraction of the cost. 

The Amiga 1300 Genlock system is available through authorized 

Commodore dealers. 
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8 Using Aegis Draw Data 

Exporting Data to Other Applications: 

The images created by Draw can be used in other applications. Bitmaps 

can be passed to any application supporting IFF (640 by 200 resolution). 

Aegis Images (high resolution) is an example, as well as other paint 

systems from other publishers. 

If you are a programmer, source code for dealing with IFF bitmaps 

is available from Commodore and is posted on several BBS's, Compllserve™, 

and BIXTM. You could lise Draw to create scenes for an Adventure 

game. In a more serious vein, you could create software that controls 

the lights and alarm in a house, and use the Draw program to create 

the layout of the house. 

The file format of Draw is detailed in Appendix C. If you want to 

deal with the drawing itself you can read this file directly. Draw uses 

ASCII files and has a "clean" file format. However, Draw generates 

most of the graphics in the program itself. For example a dimension 

is stored as (basically) two points. When Draw displays the dimension 

it calculates the distance, generates the text, and draws all the lines 

that make up the dimension. This may be difficult to accomplish in 
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your own program. Other elements that are complicated to display 

include Text, Smoothed Lines, Arcs, and Parts. 

If you want to generate Draw data , items like Lines, and Polygons are 

quite easy to create. You could plot functions by writing programs 

to create the lines in Draw file format. Once loaded into Draw, you 

could add text and patterns. This would allow you to get plotted results 

of your efforts. A function plotter program that interfaced with Draw 

might be a good product to sell as an add-on to Draw. 

It is still possible to write software that generates parts lists displays 

lines, polygons and circles, and deals with the drawing file directly. 

If you want to display the drawing there is another method that works 

quite well. When you Plot a drawing, Draw creates a file titled 

"PLOTFILE" containing the commands for your plotter. This "plot file" 

is quite simple, consisting of Draw, Move, Color, and Pattern commands 

in ASCII format. You could read this file and display the plot file yourself. 

Preparing for Pro Draw 

In the near future you will receive (you did send in your registration 

cardl) an offer to upgrade to Aegis Pro Draw. You will be able to 

upgrade for less than the difference in price between Pro Draw and 

Draw. Pro Draw adds the professional features you'd expect on a mini

computer based CAD system. 

There will be a file translator that wiJl convert Draw files to Pro Draw 

files. The work you create in Draw will be usable in Pro Draw. Some 

of the additional features in Pro Draw are: 

1. User Defined Menus. 

2. Interfaces to programming language. 

3. Attributes. 
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The best way you can prepare for Pro Draw is to take advantage of 

the Part feature of Draw. In Pro Draw parts can be assigned attributes. 

These attributes can be anything you want. You could keep track of 

cost, shipper, material, weight, whatever. By using parts in Draw, you'll 

prepare your drawings for use in Pro Draw. 
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19 Getting the Most Out of 
Your Amiga 

Hardware Pitfalls to Avoid 

The Amiga is a high powered personal graphics workstation. As with 

any high performance product there are certain things to be aware 

of. These include the quality of the display monitor, expansion memory, 

and mass storage devices. In order for Draw to be a useful tool , you'll 

need the proper hardware. Here is a brief list of the MINIMUM 

requirements. 

1. 	 Amiga 1000 Computer. 

2. 	 512K of RAM memory. 

3. 	 Color Analog RGB monitor. 

With this hardware you will be able to run Draw. In order to get 

the maximum benefit from Draw the following are HIGHLY 

recommended. 

1. 	 Expansion memory beyond 512K (1 or 2 Meg expansion 

cards). Draw has been successfully run on the Tecmar 1 Meg 
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expansion card . You MUST still have 512K of internal RAM 

in the Amiga. 

2. 	 Amiga external 3.5" tloppy drive . It helps you make backups 

and gives you more disk space for drawings and parts. 

3. High quality RGB Analog monitor. We recommend a Sony 

KV1311 CR for Draw and for Pro Draw a high persistence 

monitor (Electrochrome, Mitisibusi LP series, etc.). A good 

monitor will make your work pleasurable. A bad one can 

be torture. 

4. 	Hard Disk. Draw has been successfully run on the Tecmar 

20 Meg Drive. One of the most important features of a drive 

is the ability to recover from a "crash" of software/hardware 

on the Amiga. You should ask that the software supplied 

for the hard disk have a "Re-Verification" function. The "Re 

Verification" or "Auto-Verification" of a drive rebuilds the 

directory. The other concern is the amount of memory the 

drive uses. If you have a 512K Amiga, a drive that Llses 50K 

of RAM for it's software can prevent you from running large 

applications. Of course, if you have expansion RAM this isn't 

a big deal. 

5. 	 Plotter. Draw looks good on the screen or a printe r, but 

the plots look great' The Roland DXY 980 is an excellent 

plotter (up to 11 " to I7" paper). If you want to use another 

plotter with Draw, try to get one that supports the HPGL 

plotter language. You can configure Draw for ANY plotter, 

but this does involve some work. 

6. 	 Real time clock. A-Time'M is a battery backed up clock that 

will allow your Amiga to have the correct time. This will 

allow YOll to determine the correct date a file was last 

created/ modified. Very useful for keeping track of revisions. 

A real time clock prevents you from having to type in the 

time every time you reset or power up your Amiga. 
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If the electrical power in your area is less than dependable , consider 

purchasing a line filter. For severe conditions (power outages, brown 

outs) a battery backed lip power supply is a useful accessory. This 

can prevent hard disk crashes. You will have time to save your drawings 

before the battery runs down. 

Follow the instructions for setting up your Amiga. Make backups of 

all your software before using it. If you have purchased any additional 

hardware, you should read the documentation before installing it. This 

may sound like common sense, but it can prevent problems from 

appearing. 

eLI vs the Workbench 

The workbench is a program that gives the user a graphical , icon

like interface to the Amiga operating system. Workbench is easy to 

use. Draw will work under Workbench without problems. Why would 

you use CLI? There is one reason, ·memory. Workbench uses an 

additional 40K of memory. CLI uses less memory and is very flexible. 

We've included a brief tutorial in the use of CLI. Once you get familiar 

with your Amiga, CLI will become a useful way of "talking" to your 

Amiga. 

Printers, Plotters and Pens 

Printers are reliable output devices. Draw will support any graphics 

printer appearing on the Amiga Preferences menu of printers. There 

are several color printers that will work with the Amiga. The Okimate 

20 is a low cost color printer that uses a thermal transfer method 

of color printing. Colored "wax" is melted off the ribbon and adheres 

to the paper. The Epson JX80 is a conventional impact printer using 

a multicolor ribbon. The Diablo C 150 is a color ink jet printer. Colored 

ink is sprayed on the paper directly. Ink Jet printers are quiet and 

produce excellent output. 
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A plotter will provide the best quality Olltput from Draw. Plotters are 

also reliable devices. Since most people are not familiar with plotters 

a few words to the wise on maintenance. Pens need to be capped 

after use. Some plotters support the use of mechanical drafting pens, 

these can be refilled with ink. The mechanical pen's tips need to be 

cleaned quite often. Felt tip pens will do for most applications. Some 

plotters will cap their pens automatically, most notably the Epson HI 

80. Draw will only produce the number of colors the plotter can 

produce (Pro Draw will allow you to manually change pens) . 

When transporting plotters, be sure to protect the mechanism that 

moves the pen . This is one area where plotters are more fragile than 

printers. A spare set of pens is also a good idea. There are also pens 

for plotting on transparencies. You could use Draw to create diagrams 

on transparencies, for presentations and lectures. 
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A Aegis Draw Menus 

This appendix contains a listing of all the menus in their order of 

appearance (left to right) in the program with a brief description of 

each and page references to other material. 

Project 

New Drawing 
Open 

Drawing 

Part 

Save 

Save As 
Drawing 

Part 

Bitmap 

Opens a new window for drawing. 

Loads a drawing stored on disk into the 
current window 14-5 

Loads a part stored on disk into the 

current drawing 14-6 

Saves the current drawing to disk under the current 

file name. 

Saves the current drawing to disk and requests a 

file name 14-2 

Separates a part from a drawing and saves 
it to disk 14-2 
Saves the current view in the current window to disk 

as an IFF file 14-4 
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Plot 
Print 

Kill Drawing 
Quit 
About Draw 

Edit 

DRAW 

Sends the current drawing to the plotter 

Sends the current view of the current window 
to the printer 
Deletes the current drawing from memory. 

Exits the Aegis Draw program. 
Displays an information screen about Draw. Also 
displays the current memory usage for Draw. 

15-3 

15-4 

Undo 
Cut 

Copy 
Paste 

Erase 
Modify 

Size 

Rotate 

Distort 

Paint 

Pattern 

Weight 

Group 

Removes the last action from a drawing 11 -2 

Removes an area of a drawing and moves it 

to the clipboard 11-2 

Copies an area of a drawing to the clipboard 11-4 

Places the contents of the clipboard in 
a drawing 11-4 
Erases all of the objects in an area 11-4 

Changes the size of all of the objects 
in an area 11-5 
Rotates all of the objects in an area 11-6 
Changes the height/width aspect of an area and 

allows "flipping" to create a mirror image 11-7 

Changes the color of all of the objects 
in an area 11-8 

Changes the line pattern of outlined objects and the 
fill pattern of filled objects in an area 11-9 
Changes the line weight of all of the objects 
in an area 11-9 

Groups all of the objects in an area together 
as a part 11-10 
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Tools 

"- Line 
Rectangle 
Polygon 
Freehand 

Arc 
Circle 
Text 
Dimension 

Part 

Drag It 
Rotater 
Clone 
Eraser 
Explode 
Sizer 

Back 

Color 

Stats 

Display 

Sets the Draw tool to creating lines 9-2 

Sets the Draw tool to creating rectangles 9-2 


Sets the Draw tool to creating polygons 9-3 

Sets the Draw tool to creating 


freehand shapes 9-3 

Sets the Draw tool to creating arcs 9-3 

Sets the Draw tool to creating circles 9-4 

Sets the Draw tool to creating text labels 9-4 


Sets the Draw tool to creating 


dimension lines 9-5 

Sets the Draw tool to creating one of the parts from 


the parts requestor 9-6 


Sets the Draw tool to moving objects 10-2 


Sets the Draw tool to rotating objects 10-2 


Sets the Draw tool to making copies of objects 10-3 

Sets the Draw tool to erasing objects 10-4 


Breaks a part back into its component objects 10-4 


Sets the Draw tool to changing the size 


of objects 10-4 


Moves objects to the front of the drawing list. 


If an object is drawn first it will be "behind" 


other objects 10-5 

Sets the Draw tool to changing the color, line pattern 


and weight, and fill pattern of objects 10-6 


Allows you to adjust the position and other aspects of 


objects from the keyboard 10-6 


Zoom 

In Magnifies the view in the current window to display a 


selected area 7-9 


Out Increases the display area in the current window by 2 


times ("backing out" of a Zoom) 7-9 
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Window 

Full Display 

GridOnlOff 

Rulers OnlOff 

Crosshairs OnlOff 

Set Color 
Grid 

Background 

Rulers 

Repaint Grid 

Layers Shown 

Options 

DRAW 

Creates a new window if possible with a magnified 

view of the selected area 7 -10 

Returns the view in the current window to the full 

view of the drawing after zooming in 7-10 

Turns the grid on or off in the 

current window 7-4 
Turns the rulers on or off in the 

current window 7-7 
Turns the crosshairs on or off in the 

current window 7-11 

Changes the color of the grid in the current window 

to the active color 7-8 

Changes the background color of the current window 

to the active color 7-7 

Changes the color of the rulers in the current 

window to the active color 7-8 

Does a quick repaint of the grid without refreshing 

the entire drawing 7-6 

Selects the layers to be displayed in the 

current window 12-2 

Line Pattern 

Line Weight 
Fill Pattern 

Grid Size 
Grid Pattern 

Units 

Set Scale 
Set Rounding 

A-4 

Selects the active line type 

(solid thru dotted) 8-4 

Selects the active line thickness 8-4 

Selects the active pattern for creating 

filled objects 8-5 
Sets the distance between grid lines 7-5 

Sets the lines of the grid to one of the available 

line patterns 7-4 
Selects the type of units to be used in 

the rulers 7-7 
Sets the scale for output to the plotter 15-2 

Selects the level of precision for the drawing. 
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Format 	 Sets a drawings height, width, and origin. Also the 

paper height, width, and origin 

Preferences 

Layer 
Filled 

On 

Off 
Numeric Display 

On 
Off 

Grid Snap 
On 

Off 
Data Snap 

On 

Off 

Rounding 


On 


Off 
Smoothing 

On 

Off 

Color 

Selects the active layer 	 12-2 

When Filled is turned on all objects created will be 

filled with the current fill pattern 8-4 

When turned off all objects will be outline. 

Turns on numeric display of the cursor position. 

Turns off the display 7-11 

Forces objects created to "snap" to the nearest grid 

intersection. 

Disables Grid Snap 7-5 

Attaches objects created to others in the immediate 

area. 

Disables Data Snap 12-2 

Enables the precision level fixed with the Set 

Rounding command. 

Disables the preciSion level 12-4 

Performs curve fitting on straight line objects when 

created. 

Disables curve fitting 12-6 

Modify Colors 	 Allows you to change the hue of any color in the 

palette 8-2 
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B Hardware Requirements 

Aegis Draw runs on a 512K Amiga with one 3.25" disk drive. We 

recommend using more equipment however if you intend serious work. 

A minimum system would include: 

512K Amiga 


1 External Floppy Drive 


1 Plotter (eg. Roland DXY 980) 


A recommended profeSSional system: 

512K Amiga 

20 Megabyte Hard Drive (eg. Microforge) 

1 Megabyte Ram Expansion Card 

1 High Performance Color RGB Monitor (eg. Sony 

KVI31IER) 

1 Plotter 
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Other Options: 

Genlock 

Live' Video Digitizer 

Kllrta Digitizing Input Pad (eg. Penmollse(TM» 

Color Video Camera 

Beta or VHS VCR 

68020 Processor Chip 
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c Aegis Draw File Format 

The Aegis Draw files for Drawings and Parts are "normal" ASCII files. 

These text files can be edited with any Amiga text editor (ED for 

example). Drawing and Part files can be read by almost any programming 

language. Draw uses ASCII files to allow for easy interface to other 

programs. Draw will also be expanded into Aegis Pro Draw. ASCII 

file format makes translating these files simpler. 

ASCII files consist of text. Draw uses only 3 " types" of text. These 

are the following: 

1. 	 Integer: a whole number of the form "123" (the quotes 

do not appear in the file) . This is translated into a 32 bit 

value by Draw. Integers consist of the digits 0 thru 9, followed 

by a trailing space or linefeed. Integers are used to hold 

values like color, pattern , weight, and layer. 

2. 	 Real Number: a floating point value of the form " 122.22" 

(the quotes do not appear in the file). This is followed 

by a space or !inefeed. Real numbers consist of the digits 

o thru 9, with an (optional) decimal point ".". Real numbers 

are lIsed for coordinates, sizes, and angles. Draw uses ASCII 
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to represent real numbers because there are different real 

number systems used by Amiga software. 

3. 	 String: a stream of any valid ASCII characters enclosed by 

quotes. For example, "Hello there" (the quotes DO appear 

in the file). How can Draw allow any valid character if quotes 

are used to enclose or mark the string? The trick is to use 

the backslash ( \ ) character as a marker. For example if 

a string reads: 

Drawing of "French Style" house 

It will get written out as: 

"Drawing of \"French Style \ " house" 

The backslash tells Draw the next character is to be read 

into the string. Draw knows if a double quote (") follows 

a backslash ( \ ), the quote is NOT the end of the string, 

the quote is to be included in the string. 

What about a backslash in a string? Draw uses the same 

rule as above, any character following a backslash is to be 
added to the string. If we have a string that reads. 

3' 5" Beam\Aged Oak 

It would translate to: 

"35 \ "Beam\ \Aged Oak" 

This allows Draw to have any valid ASCII character in a 
string. 
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...... 


These are the basic building blocks of a Draw file. Draw uses Integers , 

Real Numbers, and Strings to write out the Drawing and Part files. 

Every object in Draw is composed of these pieces. 

Drawings consist of graphical elements. Draw uses an object based 

approach. This approach treats every graphical object on an "equal 

basis." Lines, Arcs, Circles, Text, Dimensions, and Parts all share 

common data. This data is collected into an object called an Element. 

Every object in Draw is an Element. The element has a fixed piece 

of data called a Header. Additional information is used to hold the 

particular information for individual objects. For example, a Circle 

needs information on location and radius. 

Draw "knows" what type of element it is dealing with by use of an 

"10". Each type of graphical element has a unique 10. Some of the 

tools create the same type ofgraphical object. Line, Polygon, Rectangle , 

and Freehand all create Polygons. 

The Element Header contains information on the size of the object, 

area it covers, color, layer, pattern, weight and flags. The diagram of 

an element follows: 

ELEMENT 

Integer 10, the 10 of an object. The lO's are: 

Polygon 1 

Circle 2 

Text 3 
Dimension 4 
Part 5 
Arc 6 

Integer SIZE, the number of bytes needed to store the 

element. 
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Real Numbers MIN-X, MIN-Y, MAX-X, MAX-Y. These 

four real numbers represent the area an element 

occupies in a drawing. A Polygon that runs from 

coordinate 0,0 to 10,20 would have values 0,0,10,20 

as the MIN-X, MIN-Y, MAX-X , MAX-Y real numbers. 

Draw uses this information to determine if an element 

is in a particular area of the drawing. 

Integer COLOR, the pen number of the element. This 

varies from °to 255. The current Draw program lets 

you select colors from ° to 16, this may change in 

the future. 

Integer LAYER, the layer the element resides on. There 

are 250 layers in Draw, °thru 249. Layer AO is number 

0, layer A9 is number 8, layer BO is number 9 ... and 

so on. 

Integer PATTERN, the line/fill pattern the element 

uses. If the element is filled the number runs from

°to 7. Zero is the solid pattern. If the element is not 

filled the number runs from °to 8. Zero is the solid 

line. 

Integer WEIGHT, the line weight of the element. Zero 

implies single thickness. One is used for double thick 

lines. A weight of two for triple thick lines. 

Integer FLAGS, information on the element. FLAGS 

consist of the following values added together. 

Filled is On 1 (bit #0). 

Smoothing 2 (bit #1). 

FreeHand 8(bit#3). 
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The bits in the flag are tested for these values. A 

smoothed, filled, freehanded element would have a 

value of 11. 

After the header of the element is written to the file, Draw writes 

the rest of the element's data out. This data is specific to the type 

of the element. For each type of element the data follows. 

POLYGON, a series of points. Draw moves the pen to the 

first coordinate, then draws to the coordinates that follow. 

Integer CONTINUE, a 1 if there is a coordinate after 

this, 0 if this is the end of the coordinates. 

Real Numbers X and Y. Coordinate values of this pOint. 

This repeats until a CONTINUE value of 0 , which is NOT 

followed by the real numbers X and Y. An example might 

look like this: 

1332245.11100.00132.50 

These coordinates wouLd result in a line drawn from 33.2,245.1 

to 100.001 ,32.5 . 

CIRCLE. Draw displays the circle as a series of lines (72). 

Real Numbers X and Y. Coordinate values of the center 

of the circle. 

Real Number RADIUS. The radius of the circle (distance 

from center to the edge). 

ARC. Draw displays an arc as a series of lines, starting from 

a particuLar angle, and proceeding counter-clockwise to 

another angle. Draw uses a "right handed" Cartesian coordinate 
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system. Zero radians is in an "east" direction from the center. 

Draw uses radians for its angles, PI (3.14... ) radians correspond 

to 180 degrees, a direction "west" from the center. 

Real Numbers X and Y. Coordinate values of the center 

of the arc. 

Real Number RADIUS. The radius of the arc (distance 

from center to the edge). 

Real Numbers START-ANGLE, END-ANGLE. The starting 

and ending angles of the arc. Draw displays the arc 

in a counter-clockwise manner, from START-ANGLE 

to END-ANGLE. Value in radians. 

TEXT. Draw displays the text as a series of lines. Text is 

displayed at a given angle (see above). Each character has 

a width and height . 

Real Numbers X and Y. Origin of the text. 

Real Numbers CHARACTER-WIDTH, CHARACTER

HEIGHT. The height and width of the individual char

acters. The height includes the descenders, the letters 

"pqg" have descenders. 

Real Number ANGLE. The angle of rotation for the 

text. Value is in radians. 

String TEXT. The actual string used by the text element. 

DIMENSION. Draw displays a dimension line between two 

points. Draw always orients the text from left to right, and 

from bottom to top (if vertical). 
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Re_al Numbers START-X, START-Y, END-X, END-Y. The 

two points to measure the distance between. 

Real Numbers CHARACTER-WIDTH, CHARACTER

HEIGHT. The height and width of the individual 

characters and arrows. 

PART. Draw displays the part by using the elements that 

define the part , and resizing, rotating, and moving them to 

the location of the part. 

String NAME. The unique name of the part's definition 

in this drawing. Each part refers to a part definition 

in the drawing. 

Real Number~ X and Y. Location of the part. 

Real Numbers SCALE-X, SCALE-y' Scale factors for the 

part. A value of 1.0 implies full scale, 2.0 would be 

twice the size. 

Real Number ANGLE. The angle of rotation for the 

part. 

Integer FLAGS, not used currently. Should have a value 

ofO. 

When Draw writes out a series of elements, it terminates the elements 

with an integer value of -1. No other values follow this. If you read 

an element ID of -1 , you have reached the end of a list of elements. 

Do not read any element information beyond the ID, until you have 

checked the ID against a terminating value of -1. 

Parts use a Part Definition. The Part Definition is a list of elements, 
with additional information, such as the unique name of the part. The 
part definition is filed as follows: 
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Part Definition. What the part is made up of. Only used 

once in a drawing. Every part definition must have a unique 

name. 

[meger COUNT. Not used curremly. May be used to 

hold the number of times this part definition is being 

used in the drawing. 

String NAME. The unique name of the part definition. 

This is the name you see in the Parts requestor. The 

part element's NAME lets Draw know what part definition 

the part is using. 

Real Numbers MIN-X, MIN-Y, MAX-X, MAX-Y. These 

four real numbers represent the area a part definition 

occupies in a drawing. If a part that used this definition 

had a scale of 1.0 by 1.0, and angle of 0.0, at a location 

of (0,0), this would be the min/max values of that 

part. 

A list of Elemems that make up the part terminated 

by a integer of -1 (as described above). No Part should 

be in this list in Aegis Draw. 

The drawing comains a list of the part definitions used. Each part 

definition is preceded by an integer of value zero. As with a list of 

elements, the list of parts is terminated with an integer of -1. This 

would look like: 

o (Part Definition) 0 (Part Definition).. -1 

Finally here is the format of a drawing. 
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DRAWING 

Integer MAGIC#. MAGIC# must be equal to the value 

32086. Draw uses this to make sure it is dealing with 


a Drawing file. 


Real Numbers X,Y. The lower left origin of the drawing. 


Real Numbers WIDTH, HEIGHT The size of the 


drawing. 


Integer FLAGS. Not used currently, should be set to 


O. 

Real Number SCALE. Number of units that correspond 

to one inch on the plotter. 

String NAME. The name of the drawing. 

A list of the part definitions. 

A list of the elements the drawing contains. 

The Part file is simply this: 

PART 

Integer MAGIC#. MAGIC# must be equal to the value 

40186. Draw uses this to make sure it is dealing with 

a Part file. 

A part definition. 

If there are no part definitions in a drawing, Draw will write out the 

-1 to terminate the list of part definitions. Draw will check to see 

C-9 



INS IDE A E GIS DRAW 

that a part's definition exists before it adds the part to the drawing's 

list of elements. 

Aegis is actively seeking submissions of software which compliments 

Aegis Draw. If you need more technical information send your requests 

to: 

Amiga Product Support Group 
2210 Wilshire Blvd., Suite 277 

Santa Monica, Ca. 90403 
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D Common AmigaDOS 
Commands 

The following commands operate from the CLI (Command Line 

Interpreter) . 

Directories 

Draw has two directories on disk directly related to the program. One 

is labeled "Part" and is used for storing all parts. "Drawing", is for 

drawing files. The directories are not required but are only supplied 

as a method of keeping files sorted. 

To select a directory for use in the CLI type : CD: Parts 

This makes the directory "Parts" active. This is like opening a drawer 

in a file cabinet. The files in the directory are now available for use. 

To see a list of files and directories or sub-directories type: Oir 

This will list the names of all the files in the currently active directory. 

To see a more detailed listing type: List 
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Using Devices 

The most often used devices are the disk drives. To access a drive 

use the change directory command but add a drive identifier to it. 

For example, the internal drive is 0 (zero) and the external drive 

is 1 (one). 

To switch from drive 0 to 1 type: CD DFl:Parts 

This command will access the "Parts" directory on drive l. 

Other devices you may want to access directly are printers and plotters. 

For example , if there is enough disk space when Draw plots a drawing 

it will create a plot file on disk. This is an ASCII text file made of 

plotter commands. This file may be sent to a plotter directly from 

the CLI. This way you can create plots without Draw. 

To send this file directly to the plotter type: copy DrawPlotDump 

to par: 

This would send the content of the file to the parallel port of the 

computer. If your plotter is connected to the serial port you would 
want to modify the last part of the command to "sec". 

Sending the file to the serial port would look like this: copy 

Draw Plot Dump to ser: 

Another important device is an internal memory area known as RAM:. 

RAM: acts like a disk drive but it is actually a space in memory. It 

supports all of the file handling commands. This device is particularly 

handy if you only have one disk drive. With RAM: you can copy files 

from drive 0 to RAM: change disks and copy files from RAM: to drive 

O. This way you can move files between disks with only one drive. 

To copy a file to RAM: type: copy FILENAME to RAM: 
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Formatting a Disk 

A disk must first be formatted before it can be used . Formatting a 

disk with data on it will completely erase the disk. The format function 

is a program stored in the "C" directory. You must first change to 

that directory or call the program directly. 

There are two parameters to the command, Drive and Name. They 

specify the drive the disk to format is in and the name to give the 

disk after it is formatted. If you use a space in the disk name you 

must enclose the name in quotes . Warning! The Format command 

completely erases any data on the disk. 

To format a disk without changing directories type: 

c/FORMAT DRIVE drivename NAME diskname 

Example: c/format drive dfO: name mydisk 

The example formats the disk in drive 0 and gives it the name "mydisk". 

If you switch directories to "C" then the "c/" part of the command 

is not needed. 

Copying Disks and Files 

The Diskcopy command is located in the "C" directory so to use it 

you must either call it directly or change directories. 

To copy one disk to another without changing directories type: 

C/DISKCOPY drivename TO drivename 

Example: c/diskcopy dfO: to df1: 

The example will copy the disk in drive 0 COMPLETELY onto the 

disk in drive 1. Warning' Any data on the disk in drive 1 will be erased 

by this command. 
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Copying a file to another disk is a simple matter. If YOll have two 

drives the command is direct. If you only have one YOll must tlrst 

copy the file to the RAM: disk, swap disks in the drive , and then copy 

it from RAM: to DFO:. 

To copy a file with two drives type: COpy filename TO drive name 

Example: copy myfile to dfI: 

The example copies the file "mytile" to the main directory of drive 

1. To copy the tile to a specific directory just add the directory name 

to the drive name. 

To copy a tile with one drive: COPY filename TO RAM: 

(When the drive light goes out swap disks) 


CD RAM: 


COpy filename TO DFO: 


CD DFO: 


Check your Amiga user's guide for more information on copying files 

and lIsing DOS commands. 
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E Creating a Plotter Driver 
for Aegis Draw 

The Aegis Draw program is configured for a Roland DXY980 plotter 

running RD·GL (an HPGL equivalent). If your plotter differs from th is, 

you will need to create a plotter driver for Draw. 

When Draw first starts up , it looks for a file titled "PlotDriver". If 

the file is found , Draw will load up the information it needs from 

it. If the file "PlotDriver" cannot be found, Draw will use the default 

Roland RD·GL driver. 

The "PlotDriver" file is an ASCII file made up of the same building 

blocks as Drawing and Part files. The building blocks are Integers, 

Real Numbers, and Strings (see Appendix C). "PlotDriver" enables 

Draw to configure itself to almost any plotter. Draw does assume some 

conventions about the plotter. The minimum requirements are: 

1. 	 The Plotter accepts ASCII commands. These commands can 

be followed with an < end of line> character «CR> or 

<CR>I<LF> ). 

2. 	 The Plotter has an origin in the lower left corner of the 

paper. 
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3. 	 The Plotter accepts movement and drawing commands of 

the form string interger( x) string interger( y) string <end 

of line>. For an HPGL plotter, a draw command would read 

as follows: 

PD;PA 100,200; 

This command will cause the plotter to draw a line to 

100,200 in plotter units. 

4. 	 The Plotter can be connected to the serial or parallel port, 

and can be interfaced as one of the printers in Preferences. 

Most plotters will work with almost any of the printer 

selections. Draw does not send escape or control characters 

to the plotter. Draw only sends text to the plotter. Baud 

rate and connection for the serial port are set in Preferences. 

To support optional plotter features (color, line patterns, etc.), Draw 

needs additional information on the plotter. 

1. 	 The number of pens, and the number of the first pen. Draw's 

colors run from 0 to 255, Plotter pens often run from 1 

to 8 (e.g. 8 pen plotter). 

2. 	 Draw assumes that the color (select pen) command is of 

the form string interger(color) string. To select pen 5, in 

HPGL, the command would read: 

SP 5; 

3. 	In order for line patterns to be used in plots, Draw needs 

to have the 9 commands that set the line pattern to the 
correct value. These commands are assumed to be a string. 

To get a dotted line in HPGL the command would read: 

LTl; 

.~. 

. ~ 
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Draw needs to have information on the plotter's resolution. "PlotDriver" 

stores this as a Real Number, corresponding to the number of plotter 

units per inch of paper. For the Roland DXY 980 this value is 1000.0. 

Draw also needs to have the thickness of the pen tip, in inches. This 

is typically a value of .01 or .02 inches. Draw uses the pen thickness 

to draw the "double thick" and "triple thick" lines on the plotter. 

Draw also uses this "thickness" to hatchfill shapes properly. 

Draw also needs the size of the plotting surface, in inches. This is 

typically smaller than the size of the paper. Draw uses this to insure 

that the user does not overwrite the paper. 

PlotDriver. 

The format of the PlotDriver file follows. NOTE: It requires 

some expertise to create a file with these commands. Aegis 

will provide driver flies for every plotter we can obtain for 

testing. Contact us if you have special requirements. Each 

of the componen ts of the PlotDriver file can be on a separate 

line. This is optional but it does improve readability. Every 

PlotDriver file must have all these components. Color and 

Pattern strings can be set to "", if the plotter does not support 

these functions. 

Magic Number, an Integer ofvalue 42586. This allows Draw 

to verify that the file is a proper plot driver file. 

Resolution, a Real Number. The number of plotter units 

in one inch. For an HPGL plotter this may be 1000.0. 

Width, a Real Number. The width of the plotting surface 

in inches. Draw assumes that 0,0 (the plotter origin) is the 

lower left corner of the paper. You should allow for margins. 

Height, a Real Number. The height of the plotting surface 

in inches. 
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Thickness, a Real Number. The number of inches that equal 

the pen thickness of the plotter. Typically .02 inches. 

Starting Pen, an Integer. The number of the first pen for 
the plotter. This is ignored for single pen plotters, BUT must 

be included in the file. 

Number Pens, an Integer. The number of pens for the 

plotter. Must be included, even for single pen plotters. 

Plotter Setup, a String. The command to initilize the plotter. 

Plotter Cleanup, a String. The command to "clean up" after 

a plot. This may be the command that caps the pens, or 

"homes" the pen after a plot. 

Move Command, a String. The command to lift the pen 

and move to an absolute coordinate on the plotter. The 

first part of the command (e.g. "PU;PA "). 

Move Separator, the String that separates the digits in the 

move command. For example "," ... a comma. 

Move Terminator, the String the ends the move command. 

For example ";", a semicolon. Draw allways sends a < end 

of line> sequence after a command. 

Draw Command, a String. The command to lift the pen 
and draw to an absolute coordinate on the plotter. The first 

part of the command (e.g. "PD;PA "). 

Draw Separator, the String that separates the digits in the 
draw command. For example "," . .. a comma. 

Draw Terminator, the String the ends the draw command. 

For example ";", a semicolon. 
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Color Command, a String. The command to change the 

pen. The first part of the command. (e.g. "SP "). If the color 

command is a NULL string (e.g. ""), Draw assumes the plotter 

has only one pen. 

Color Terminator, the String the ends the color command. 

For example ";", a semicolon. 

Line Patterns, 9 strings that set the line patterns. For 
example "LT 1 n. If Draw sees a NULL string "", Draw assumes 

that line patterns are not an option for this plotter. The 

PlotDriver file must have these 9 strings in the file. 

Here is an example of a Plot Driver file for a RolandDG DXY 

980 running RD-GL (HPGL equlivant). The commands have 

been grouped on separate lines for readability. 

42586 

1000.0 15.0 10.0 .02 


1 8 


"OF;" 


"PU;PA " "," , 
" n 

" PD;PA " "." 

II . ""SP" , 
liLT; " 

" L T 3,3;" 
"LT 2;" 

"LT 2,1;" 

"LT 4;" 
"LT 5 ;" 

"LT 1;" 

"LT6;" 
"LT 3;" 
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AmigaDOS - The Amiga Disk Operating System. 

Cancel - To back out of an operation without performing any action. 

Usually performed by pressing the Menu (right) mouse outton. 

choose - To pick a menu item. You normally choose menu items 

with the Menu button. 

click - To press and release a mouse button. 

clipboard - An area in memory that works as a temporary holding 

space. Items may be cut or copied from drawings into this area for 

later pasting into the same or other drawings. 

Clone - To make a copy or duplicate of an object. Performed oy 

selecting Clone from the Tools menu. 

close - To remove a window or requestor from the display. To put 

away a tool , drawing, or file. 

G-1 




INS IDE A E GIS DRAW 

color - In this manual it lIsually refers to one of the slots in the 

Color Map. 

Color Bar - The set of colors availahle for use displayed as a bar. 

These appear in the Color Menu and the Color Modify Requestor. 

Also known as the Color Palette. 

Color/Map - A tahle used to translate from the numerical representation 

of data in the computer to the representation as colors on the screen. 

The Color Map can he thought of as a series of ink wells numhered 

from left to right . The type of ink in the wells can change, but a drawing 

that calls for ink 0 will use the ink from the left-most bottle. Individual 

Color Maps can he stored on disk as a ".col" file (color ). 

Color Requestor - The requestor YOli use to change the colors in 

the Color Palette. Reached by selecting Modify Color from the Color 

menu. 

copy - Refers to an editing process where items are duplicated from 

a drawing into the cliphoard. 

cursor - The icon that moves on the screen when you move the 

mouse. you lise it to select menu items, work gadgets, create objects, 

etc. 

cut - Refers to an editing process where items are removed from 

a drawing and moved to the clipboard. 

disk - A magnetic medium for storing and retrieving information. 

The little plastic things with the metal strip that opens and closes. 

edit field - An area usually found on a requestor where text data 

is entered. All text information, the backspace key, and the arrow keys 

may be used inside the field . You gain entrance to an edit field hy 

clicking on it. 
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filled - Refers to objects displayed in a drawing. If they are filled 

they appear solid or contain a pattern. 

fill pattern - One of eight patterns ranging from solid to mesh weave 
used to fill objects in a drawing. Used in conjunction with the Filled 

preference under the Preferences menu. You change the fill pattern 

by selecting Fill Pattern from the Options menu. 

highlight - To display something in a way that distinguishes it. 


Normally, something is highlighted to indicate it is selected. 


icon - A visual representation of a tool or function. 


Menu Bar - A strip at the top of the screen containing menu titles 


and instructions for the selected function. 


Menu button - The right hand button on the mouse. 


Object - Any thing such as a line, circle or polygon that can be 


isolated and moved. This includes multiple objects grouped together 


as a part. 


open - 1. To make a tool availble for use. 2. To retrieve a file stored 


on disk. 3. To display a window or requestor. 


Pendown - Pressing down on the Selection (left) mouse button. 


Penup - Releasing pressure on the Selection (left) mouse button. 


Pixel - One of the individual points that make an image on the screen. 


Polygon - An object defined by a number of points and straight 


lines between these points. 
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requestor - A bounded region on a screen used to give information 

to a tool or drawing. It appears as a window when you select certain 

tools. Most requestors have gadgets that control different aspects of 

the tool. When you quit Draw a requestor appears asking if you really 
want to leave. There are two buttons "Quit" and "No" to answer the 

request. 

save - To copy something to a file on disk. 

Screen - The display area of the monitor, or the rastor that holds 

the background and all other objects drawn on top of the background. 

select - To pick an object or gadget by pointing to it with the cursor 

and pressing the Selection button. 

slider - A gadget you use to pick within a range by dragging a marker 

along a line. 

window - 1. Program window, the current window Draw is running 

in on the Amiga. 2. Drawing window, a work area where draWings 

are made. Each window contains one drawing. 3. Requestor window, 

a requestor area on the screen, see requestor. 
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About Draw. . . . . . . . . . . . ........ . ........ 16·2, A·2 

Amiga FFP .. . .. . ..... . .. . ................. .. .... 1·5 


Copy. . ..... . . .... ... . .......... 3-4,5-1,5-2,5·3, 

11-1,11-4, A·2 


Cut .. . ............. , ... ' " _ 3·4,5-1,5-2,5-3, II-I, 


Arc...... . .... 3-4,4·9,4 · 10, 4·11, 9·3,A·2 

ASCII...... .. .. . .. . ...... . ... 18-1, 18-2, C-I, 0-2 

ASpect. . . . ........... . ........ _............. 12-5 

aspect ratio ............. . .... 7-2 

Aztec C ......... .. .. . .. . .... . ...•.......... .. ... 1-5 

Back ............. ... _.. . . . .......•........ 10-5, A-3 

Background.. .. . .. . . . .. ... .. ..... 2-4,7 ·7, A-3 

bitmap .. . .. . .. . . . .. . ...•. . .. • ... . . .. ........ 2-1 , 2-2 

Bitmap . .. . .. ......... ... ........ 14·4,14-5,18-1, A·I 

Buttons ................. ..... ................... 3-8 

CAD .................. .. . 1-1,1-2,1-3,1·4,1·6, 2-1 , 3-8 

Cartesian coordinate. . . . . . . . . . . . . . . . .. . ... . .. 2-3,9-4 

CO .......... . . .. . . ......... . .... . . . ........... 0-1 

CHIP memory ..... .. . . . , .•. . . . .. . . .. ........... 16-2 

choosing ......... . .... . .... . .. . ...•........... . . 3·2 

Circle .......... . ... . ................... 2-5 , 9·4. A-3 

circles. . ..... . . . . . . . .... _. . . . . . . . . . . .. ... 3-4 

CLI ..... . ...... . ..... • ..... 3·1, 16·1 , 19-3,0-1 

clipboard . ..... .......•.. . .•..... .. ... 5-1, II-I, 11-4 

Clone ........ .. ..... , ....... .. .. 4-12, 4-13, 10-3, A- 3 

close .................... ... .................... 7-3 

Color _............... .. .... 2-5, 3-6,8-4 , 10-6, A-3, A-5 

Color Analog RGB Monitor ................. ... ... 19-1 

color palette .... . . . ................. . .... 8- I, 8-2, 8-3 

Colors ...... . .... , .... . .... , .... ... ..... 3-3, 3-5, 8-1 

coordinates .... . . . .. . . " . , .. _.. .. ........... 1·2, 2-3 


CORE .......... . .. .... ....... 1·5 

Crosshairs ... .. ........ . , .•.......... _.. 2-5, 3-5, 7-11 

Crosshairs On/ Off_. . . ........... . ... 7-11, A-3 


11-2, 13-2, A-2 

Data Snap ....... , .. . . ... , . . .... . .... 2-5,6·8,7-5 , 9-4, 


12-2, 12·4, A-5 


DEC POP-II ... .. .... .. . .. .. . . .. ................. 1-4 


Drawer .. _........... . ............... 14-1 , 14-5,14-6 

Drawing .. .. ..... .... .. ..... ..... 4-14 , 14-2, 14-5, A-I 

Edit .................... , ....... 2-5 , 3·3, 3-4, 5-1,5-2, 


digits of precision. . . .. . .. . . . .. . . . . .. . . . . . . .. . . .. 12·4 

Dimension ......... . . . . .. ... . . ,., . ..... 6-10, 9-5, A-3 

Dimension Lines .... . ........ . ... , ......... .. 3-4,9-5 

Dir ..... . ....... . . . . . . • ..•.. . .................. 0-1 

Directories . .. . . . . . . ... .. ....... ... . . ........... 0-1 

directory . . .. ....... . ..... . ............... 14-1,14·2 

Display ..... . .. .. ....... ..... . _.. 3-3,3-5, 3-6, 5-6, A·3 

Distort ........ " ... ... . . . ................. 11-7, A-2 

double click..... ...... . .. ....... .. ... . ..... 3-7 

Drag.......... .. ...... . .... . ...... . . . .... 4-14 

Drag It. ..... ... .......... . .... .... 4-12, 5-5,10-2, A-3 

Dragging .. _...•.. , . . .. . .... . .. . ... . .......... . .. 3-7 


11-1,11 -3, 13-3,16-2, A-2 

Edit Boxes . , . , . . • . . . . . . . ........... 3-8 

Erase ................. .. .. .. ...... 2-5, 11-4, 11-5, A-2 

Eraser ................... . . . . . ........... " 10-4, A-3 

Expansion Memory . ... . .. .......... .. ... . .. 1-2 

Explode ......... .. ........... 6-4 , 10-4,11-2, 13-5,A-3 

FAST memory ........ . ......... . . ... ........... 16-2 

File ... .. ....................... 4-14,4-15,14·1 , 14 -6 

Fill Pattern. . . . . . . . . . . . . . . ... 2-5,8·5. A-4 

Filled ............. .. ... . .. 8-4,8-5,9-2, 10·6, 11-9, A·4 

Format.... . ............... 6-11 , 7·6, 12-5,12-6, 


15· 1, 15·3, A-4 

Format Requestor . . . . . . . . . . . . . . . . . ........ 12-5 

Freehand ............ . ....... ... .... 3-4,9-3, 16-2. A-2 

Full Display ......... .. . . ... ......... 5-7.5-8, 7-10. A-3 

Gadg~ ts ....... . . ... . . . . . . . ....•........... . . ... . 3-8 

Genlock........ .. .. .... ........ 17-1 

GKS................. .. . ........ . ........ . 1-5 

Grid .. ... . .. . .. ......... 2.4 , 3-5, 7-1,7-4,7-8, A·3 

Grid On/ Off. _... , .... , . . ... . ........... 7-4, 14-4, A-3 
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Grid Pattern ... ... , .... . ....... ............ .. 7·4, AA 

Grid Size ....... , . . , . . . .. 3·5,7·4, 7·5, A·4 

Grid Snap . , . , .. , ... . ... 2·5,6·8,7·4, 7·5, 7·6, 


7·11 ,7·11 , 10·1, 12A, A·5 

Group ....... ... . ..... . ... ..... 6·2, lOA, 11·2, 11·10, 


13·2, 13·3, A·2 

hard disk ... . .... .................. ..... ...... 19·2 

height / width ratio........ ... .. ... ..... . . 11 ·7 

High Resolution Non·lnte rlaced ..... .. , .. ..... , .... 2·3 

HPGL .. ........ .................. ...... .. .. 15 ·3 

IBM 360 ... .. .. . ....... .. ..... , ............... .. 1·3 

IFF ..... ...... ............ .. .. . .. ..... 2·1 , 14·4, 18·1 

In . . ............. .. ........ A·3 

In Stock ... . ............ .. ... .. . ......... .... 6·4,9·6 

Kickstart ....... .. .... .... . . , .. . ....... , . , .... ... 3·1 

Kill Drawing ... . . . . . . . . . . . . . .... A·2 

Label ..... . ................. ... .... 5·6, 5·8 

Layer ...... . .. 6·5,6·6,6·7,12· 1,12·2, 12·3, A·4 

Layers...... ............. 2·3,2·4 ,3·5, 12· 1 

Layers Shown ..... . . . , ......... 6·7, 6·9, 12·2, 12·3, A·4 

lazer disk ........ . . .. . . . , . . . . . . . . . . . . . . . . . . 17·1 

Line ..... ....... . .. . . . .. . . , ..... . ..... . 9·2, 16·2, A·2 

Line Pattern . .. . .. . .. 2·5,4·9,4· 10, 8·4, A·4 

Line weight .... , , .. . , ..• . . , ...... 2·5,4·7,4·8,8·4, A·4 

Lines . . . . . . , . . . . . . . . . . . . . ...... . 3A,4·2 

List ......... . . .. , ........... . .... . ...... . 0·1 

memory ....... ,., .. . .. .. . . . .. . .... . . 16· 1, 16·2 

Menu Bar .. . .. ...... , .............. 3·2 

Menu button ...... .. ..................... . ...... 3·7 

mirror image. . ....... . ... ........ .... 11 ·7 

Modify .................. . ,·4 , 5·5,10·6,11·5,16·2, A·2 

Modify Colors ..... . , . , . . .. 3·8,8·2,8·2, 8·3, A·5 

Mult i·tasking .... .. .. .. .............. 2·1,15·2, 16·2 

Name ........... ... , . . ........ 6·4 , 11 · 11 ,13·4 

New Drawing .. . ... .. ... ........ ..... . .... 14·5, A·I 

Numeric Display ........ ....... 2·5,3 '5,7· 11 , 7·12, A·4 

Open .... ........... 3'3,3·4,4'15, 1:\·6, 13·7, 14·5, A·I 

Options ..... ........ ........... 3·3, 3·5,4·7, 11·9, A·4 

origin ...... ,.. . .... . ............ 2'3 

Origin .... .. . , . . . . . , . . . . . . . . . ..... ...... 12·5, 12·6 

Out ......... .. .. .. , .... , .,., , . .. . ... . ........ .. A·3 

Paint . . . . . . . . . . . . . . . . . . . .... . .. , .. . . , .. 11·8, A·2 

paper aspect .... , .... , .. ,. .. . . .. . ... .......... . I 2·7 

paper origin .... .. . . .. , . .. . . .. , . . , , , . , . . . . . . . . . 12·6 

paper size ....... , . . ......... 12·6 

~~~....... ............. I~ 


Part.......... . ....... 6·1 ,6·2,6·3,6·4,9·6, 
9·6,11·2 , 11 ·10,13·1,13·:\, 

13·4, 13·7, 14·2, 14·6, 16·2,18·3, A·I, A·3 
PartS Requestor. .. .. .. .. .. 13· 3 
Paste ......... ........... ...... 3·4,5·1, 5·2,5·3, 11 · 1, 

11 ·2, 11·4, 13·2,16·2, A·2 
Pattern ......... . .... . .... . ... .. .... 11·9, A·2 
pixel. ...... ... . ..... . ... . .. , ... 1·2,2·2,2·3, 5·5 
Plot .. , . , .. , ... . , . . ... 6·1 2, 18·2, A·I 
plot file. . . . . . . . . .. . ..• .. , . , . 15·2 
Plotter .......... . . . . .. ... . .•.. , . . . . . . . ,.. .. . 19·2 
plotter cabling . . .. . .... , .. .. , . . , . . 15·4 
Plotter. driver . . . . . . . . . . . . . . . . 15·3 
Plotting. . . . . . . . . . . . . . . . . . . . . . . . . . . . . 15·2 
Polygon.. ..... ... .. .. . . .. .. .. 4·4 . 4·6,9·3, 16·2, A·2 
Preferences. . , . . . . . . . . . . ... 3·3,3·5. 15·4, 15·5, A·4 
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Print ....... . . ". " . .. "., .. . .... 6·12, 12·6, 15·5, A·2 
printer ....... , ... . , ....... ,.... ..... .. . ..... 15A 
Printers .... , ....... , .... . .. . . ... . ..... ........ . 19'3 
Project ......... . , . .. . , .. , . • , . . .. . ... 3·2,3·3,3·4, A·I 
Quit............ . . . ... , ............... A·2 
radius. . . . ... . . ... , . • , .... . . • . . . ............. . 2·3 
RAM ..... . .... ... .. ... ... .... . . . ... 16·1,16·2 
Real Time Clock .... , .. . ..... ...... ... . . . .... ... 19·2 
Rectangle. . . . . . . . .. . .... .. 3·4,4·4,4·5,4·6,9·2, A·2 
Repaint Grid •.... , . . . . . . ... 7·6, AA 
Reset.. ... .... .. , . . .. , . . .. . . . . . ......... 8·2 
resize .............. , . .. .... .. .... .. , .... .. , . . .. 7·3 
resize box. . . . . . . . . . . • . . . . . . . . . . . . • . . . . . . . ... 4· I 
resize window. . . . . . . . . . . ....... ......... 4·1 
RG8............. . . . . . . ............ 8·2 
Rotate .4·13,5·3, 11·6, A·2 
Rotater . ............•.... 4·14,5·3.5·5,10·2, 10·3, A·3 
Rounding ....... . , .. .......... ..... 2·5.7·5, 12·4, A·5 
roundoff error ....... , .. . .... . ..... ........ ...... 7·5 
Ruler .. ..... . ...... 2·4, 3·5, 4· 1, 7·1. 7·6, 

7·7,7·8, A·3 
Rulers On/ Off ..... , .... , . ... , . . , .... . ... .... 7·7, A·:\ 
Save ....... ......... ............... ..... .. 16·3, A·I 
save a part ..... .. . , . . , ............ ........ ..... I 3·6 
SaveAs ...... ............ ... 4· 14 , 13·6, 14·2, 16·3,A·1 
Sca le.... ........... ......... . ... 15· 1.1 5·2,15·4 
Scaled. . . .. I 5· 3 
scroll. . . . . ..... .. . .. .. . .. , . , ... . . . . .. . . . ..... . 7·2 
Scroll Bars ....... , .•.. , .. , ...... .. . . 3· 7 
scroll controls . ..... . . ............ .. , . . . 7·2 
selecting. . . . .. , .. , . , . ................... 3·2 
Selection button ..... . , . .. , . , ....... , ....... . .... 3·7 
Selection frame. . . . •.. . .... . . , .. 11·3 
serial . .. . . .......... . .. . . . , . . . .... , . , ....... ... 15-4 
Set Background ...... .. , .... , .... . .. ........... .. 3·6 
Set Color...... ... ... . .... , .. , .... 7·7,7·8, A·3 
Set Rounding .... , .. .. , . , . . , .. , . . , , . . . ...... 7· 12, A·4 
Set Rulers ........ .. , .. , . . . . . . . . . . ....... 3·6 
Set Scale. . . . . . . . . . . ........... . .......... AA 
Size .... ................ .......... .... 11 · 1, 1l ·5,A·2 
Sizer .... .......... .. . . .... . ....... 2·5, 10·4, 10·5, A·3 
Sliders , . • . . . . . . . . .............. 3·8. 7·2 
Smoothed . ........ . ....•. . . . , . . . . . . . . . . . . . . . . .. 10·6 
Smoothing .......... , .. , ... .. ..... 9·3, 12·6, 16·2, A·5 
Stats ......... ......... . ...... .. ....... 10·6, 10·7, A·3 
Storage Requestor...... ............ .. 14·1 , 14·3 
struc tured drawing ...... . , . . . . . . . . . ... . .. 2·3 
sub·menu ... . . . . . . . . . . . . ... 3·2, 3·3 
Text.......... . . . ... .... 3·4,5·6,5·7,5·8,9·4, A·3 
Text Label .... .. . . . . . . .. . ............. . ...... 9·5 
Tools. . . . . . . . . . . . . . ..... 2·4, 3·3, 3·4 , 4·2, 4A, 

4· 10, 9·1,10· 1, A·2 
Undo .... . , .. . . . . . . .. , .. ..... . 3·4,5·2, 5A, 10·4 , 

11·2.16·3, A·2 
Units ...... ............. ..... .. ....... . 7·7, 12·6, A·4 
Using Parts .... .. . . .... . .. . . , . . 13·2 
VCR ... .......... . 17·1 
video. . ..... ,.... . . 17·1 
water cooler. . . . .... . , ...... ......... 6· I, 6· 3 
Weight...... ..... .. . . . . ....... .. 11 ·9, 11 · 10, A·2 
Window......... .. ... . . ... 2·4 , 2·5 , 3·7,7.1. A·3 
Window Back gadget.. .. .. . • .. .. . .. .... .. . 7·3 



IN 0 E X 

Window Forward gadgel .....•... ... .... ..... ..... 7·3 
Workbench ....... . .... ... ....... 3·1, 12-7. 16· 1. 19·3 
X,Y coordinales .. .. ...... .. .. ...... 7·11 
Zoom . . . ... . ..... . .. 2·3.5-5, 5·6, 5·7, 7·8, A-3 

Zoom In ......... . .... . .. . . .. . .. .... ... 2·5.7·9, 7· 11 
Zoom QUI ......... .. .•....•.•..•.... _ . ... .. . 7·9,9·6 
Zoom Window .... ... ............ .. 1'3,5-5, 7· 10. 16·2 
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